No repeat in Broadacast mode

How can one remove the repeat setting in broadcast mode for XBee 868LP? We do not want the receiving node to retransmit the packet. Is this possible?

Sure it is, Just set the BH (Broadcast Hops) command to a value of 1. This tells the radius of 1 hop not to re-broadcast the transmission. You can also do this by setting the TO option bit to 0x40 which will tell the transmission to be treated as a Point to multi-point transmission instead of a mesh transmission.