No serial communication?

I am using Xbee Pro S1 modules and an 802.15.4 Xstick. I can not get them to communicate at 9600 baud. I have verified the configuration settings and double checked the destination addresses on both sides. The radios are working as I can remotely configure one radio from another. The serial ports are working in that on a module I can change settings via the serial port.
I have updated the firmware to the latest and greatest. One is configured as a coordinator and the other an endpoint.
Thanks in advance - I am at a complete loss to find anything else wrong.

Try disabling API mode on your XStick. (ATAP0)

Tried all different configurations. Weird, it’s communicating from the Xstick to the S1 module but not the other way. Have reentered addresses and tried with both 16 bit and 64 bit addressing.
ATND discovers the other module from both sides. I alsso monitored the supply voltage during transmits to rule out power drop outs, 0.001v fluctuation.

Very strange…

Are you able to enter command mode on the modules that are having issues?