XBee Pro S1 not communicating with XCTU

Like so many of the posts on this forum I am having problems trying to get my XBee-Pro to communicate with XCTU

I have tried all the baud rates under PC settings and all I get returned is “unable to communicate with modem”
If I have the enable api checked I get the message
"communication with modem ok
Modem type = name unknown (ID…)
Modem firmware version = "

Under terminal
If I type in +++ - it is echoed back to me, I dont receive an ok

Under modem configuration, I get a message "info action required "
I have followed the instructions there, and still nothing.

I have 2 xbee pros s1 out of the box.
I have pin 2 and 3 connected to a max232
and then a cable coming from the max232 to the computer.
I have the receive, transmit and ground connected and have jumpered 4 to 6 and 7 to 8.

When I have the basic comms right, I want to connect teh XBee to a pic18f452.

Any suggestions as to how I can get these XBees to work? Both are doing the same.

Many thanks

For a firmware update, connections to DIN and DOUT are not sufficient - you need RTS and DTR too. If you check out the first pinned post at the top of this forum (“Xbee Resources”) you’ll find the details in Q6 of the FAQ. Then if you still have trouble you might also need Q10 and Q11.

Hope that helps.

Hopefully connecting up the RTS and DTR will work

But to clarify something that I am unsure of.

If using my pic - via TTL I send it +++, I should get the OK back. Because I tried this and I didn’t receive anything back from the modem.
Using the +++ will allow me to set my baud rate, id and the rest?


Yes, you can set baud rate, ID and other parameters.

Response “OK” after entering +++ indicates you have succeccfully entered command mode and you can issue AT commands.