Other ZigBee devices

Hi there,

i would like to join the mesh network with devices/routers from other vendors. Is there something i should care about? Special PAN IDs? Channel? Or something else?

I moved your post from the ZNet 2.5 to the Zigbee Pro featureset forum, since Zigbee Pro featureset is most likely what you’ll be using to maintain compatibility with other vendors.

As far as things to care about, common PAN ID and channel are required. I’d also recommended getting the association working in the clear first, if Zigbee encryption will eventually be used. This way you can troubleshoot the association without having to worry about common keys, etc. as being a possible cause for not communicating. Once the devices are associated and communicating, then try adding encryption if that’s the intention.

Hi there.
I wish somenoe could help me. I have one data collector(coordinator) and four routers, all of them with ZB firmware. I intend to create a mesh network in AT mode.
To do that, I configured the NI parameter of each router (S1, S2, S3 and S4). On the coordinator’s software I programmed the following sequence:

  1. Send ATND command to discover all routers; (It is done just once)
  2. Send ATDN command with the name of one routers(example: ATDNS1);
  3. Data transfer from router to the coordinator;
  4. Send ATDN command with the name of another router(example: ATDNS2);
    The problem is: In the beggining, the ATDN command returns OK, but after some polls, ATDN command returns


May I suggest looking at your code and making sure it is sending the same thing every time. You may want to verify this on a PC first before moving to a mC.


If the vendor is not using a Vendor specific profile, then yes the XBee ZB modules are able to communicate with other vendors ZigBee devices. However, you may need to adjust the ZS command so that your XBee matches the specific ZigBee standard they are using.

Making some tests, I could reach to better result by inserting a delay, as written below:
1.+++ (coordinator sends)
2.OK (coordinator receives)
3. Delay of 800ms;
4.ATDNS1 (coordinator sends)
5.OK (coordinator receives)

The problem is: I does not work a delay shorter than 800ms.

May I suggest you test this with something like LabView? I think you will find this does function as expected. You may just need to adjust a few of the timeout settings or your code.

Dear friend.

My first concern is: Am I at the right way to build a mesh network by using ATND e ATDN commands (I went this way because I read an article at Digi website about mesh network range test)

My second concern is: ATDN command might be used in fast speed, I mean, I have to poll each router at least at 300ms. Is it possible?
I am following the same sequence that digi recommends:
+++(wait for OK)
ATDNS3(for example)
OK or ERROR (at the first 8 times I receive OK, but after that it varies from OK to ERROR and vice-versa).

I hope you can help me.

Bruno, it would be useful to know what version of firmware is loaded when talking about errors with AT commands. Which version of firmware is loaded on the module exhibiting this behavior?

Hi. Sorry for the late repply.
I have checked the firmware version: Version 2x41.
Do you want me to post my configuration for coordinator and routers?

No, but I think you’ll want to try upgrading to 2x64 first, before pursuing this any further. Looking through the 2x64 release notes I see the following bug was fixed:

DN command returned ERROR status even if a valid response was received.

Here’s the ZB firmware download page:

Thanks a lot friend.
I will update de firmware version tomorrow and I will repply you later.
Once again, thanks.

Just one more question, I have read the firmware update document and I had a doubt in this sentence:

Route discovery is disabled on devices with AR < 0xFF (concentrator devices). These devices must use source routing to send data to remote devices. (Set AR to 0xFF (default) to enable route discovery.)

Let me see if understood:
It means that, for my application with MESH, my collector (coordinator) must be configured with AR<0xFF, and all my routers must be configured with AR=0xFF?

Hi there.
I updated the firmware version but nothing have changed.
The bug of the ERROR message persists.