PE Micro Not Recognized. Help!!

I’m having a very frustrating time with the PE Micro Multilink. I have now tried the following configurations:

Windows 7 64-bit
Windows 7 64-bit + XP Mode
Windows 7 64-bit + VirtualBox w/ Windows 7 32-bit
Windows 7 64-bit + VirtualBox w/ XP 32-bit
Windows 7 32-bit
Windows XP 32-bit

Under NONE of these configurations has my PE Micro Multilink been discovered. I have tried installing CodeWarrior 6.3, CodeWarrior 10, The XBee DevKit, and the drivers from PE Micro (v10) for the Multilink. What the heck is going on and why is it so complicated???

In every case it simply comes up as an Unknown USB device. Yes, I have tried different ports. Please help or I’m going to have to send this all back.

Thank you.

Sounds to me like a bad P&E Micro device. Windows 7 has the drivers already included. It should be a matter of plug and play. Now it could be just a bad cable, so I would try that. The acid test would be to see if the device installs in a different computer. I would give support a call at 1-877-912-3444 and see about a RMA. BTW - CodeWarrior 10 is the version you want to have installed. If you install it first then the install also includes the drivers.

Yes! After weeks of sending stuff and getting new stuff everything is working! It was in fact bad hardware. Curse you hardware gods…thanks to everyone who lead me to this conclusion!


Sorry for pulling up the question but I have a problem on VirtualBox and I can’t have the “PEMicro” menu enable… The Multilink is correctly installed but CodeWarrior don’t want to see it!

Thanks for your help

My message on Freescale Forum