PortServer TS 2 H

We are installing several Digi PortServers TS 2 H, and when installing the digi driver on AIX 5.3, and run the stty-ncxa command, we get this error message:

/usr/lbin/tty/stty-ncxa /dev/tty5
/dev/tty5: Resource temporarily unavailable

Any idea’s on what is causing this error message. We see this on some servers and not others?


Here are some items that should be checked in an effort to determine why the port is not accessible on those specific units:

  1. Confirm you are able to communicate with the PortServer unit using ping and telnet.

  2. Confirm the RealPort socket is not being blocked:

The RealPort driver communicates using the 771 TCP port. This port number will need to be opened firewall settings, so that it is accessible. To confirm the socket is opened, telnet to it from the AIX host:

#  telnet [IP_of_digi_unit] 771

If an error is seen, it would indicate something is blocking the 771 socket. If a connection is established, it is normal to not see anything (blank) or possibly some garbage characters. To disconnect, issue ] followed by entering “quit” at the telnet prompt.

  1. Review the port settings from the PortServer root prompt:

    #> set port ra=*

Any port that is going to be used by RealPort should have:

o dev - Needs to be set to rp or prn.
o auto - Needs to be set to off

NOTE: You can use the Web Interface to verify the “RealPort profile”, as well.

  1. Check the Flow Control settings:

    #> set flow ra=*

Any port using RealPort, should have all signals off except ixon and ixoff and possibly altpin. Altpin should be “off” when connecting a Digi 10 wire serial cables and “on” for 8-wire serial cables. Less than 8-wire cables need to turn “on” the forcedcd value. ALL OTHER SETTINGS SHOULD REMAIN AT THE DEFAULT VALUES. All other port settings, such as, baud rate, flow control, character bits and parity are configured on the AIX RealPort host (via smit) and not on the PortServer unit itself.

  1. Check the authorization table:

    #> set auth

Will show settings like the following:


Realport should show “o” for all RealPort ports. The ports are indicated across in groups of eight. In the example above, all ports are set correctly in the RealPort column except ports 5 and 10 (which are possibly being used for non-RealPort connections as indicated by the “-“ in position 5 and 10). The example above represents a 16 port unit. The IPaddr and Mask settings should contain all zeros and only one “Ind” entry should exist.

Message was edited by: userid0

Message was edited by: userid0

Message was edited by: userid0