PortServer TS 2 POST code upgrade

I performed POST code upgrade to 82000751_D.bin (with command “boot load-boot”, there was a message about successfull upgrade) and restarted my PortServer TS, then PWR lamp blinks 3 times and not flash.
Unit appears to be dead, except User Diagnostics console.
Changing OS code through the console has no effect.

Is there any method to restore old POST code?

You can try connecting a terminal or PC to the unit’s first port at 9600 baud/8/1/None. Power off the PortServer unit. Then power on the unit, press the reset button on the PortServer unit, while at the same time, tap the letter ‘v’ on the attached terminal/PC.

This should present you with the Diagnostic menu. Here there are options for uploading firmware/post.

If you are unable to get to the diagnostic menu, I recommend contacting Digi International Technical Support for further assistance.

Yes, sure, Diagnostic menu is only thing that works now. But in the menu there is only OS upgrade item (‘C’). It seems to be ‘OS upgrade’ procedure loads firmware files only. It decline POST files.

I can’t find where is POST load option.

Have you tried using the hardware reset button on the front to get everything back to factory defaults? I’d say it would be worth a shot. This might be something that will require an RMA, which you’d need to get through Technical Support.

Yes, it was the first ting I did.

There is another question. What I did wrong?
I think my PortServer TS is pretty old and can’t be upgraded with modern firmware versions…

Yes, there are two different versions of POST images for older and newer units. The difference being, that the older units have 2 Meg. of memory, where the new units have 4 Meg.

The Digi web-site, indicates which Firmware/POST images should be used based on the part number found on the units.