PortServer TS4 Problems

I have three older PortServer TS4 units - part #50000723-03.

I tried to upgrade the firmware - Post image 82000679_D.bin and firmware image 82000716_L1.bin.

None of them would accept the Post image but two upgraded the firmware fine. The new menu is however not the same as shown in the manual, but appears to be a expanded version of the original menu - I guess this may be because the Post was not upgraded.

The last one hung during the upgrade. I left it for a long time, but eventually removed the power. I followed the procedure to reset to default and now get the following LED patterns on power up: 1-5-1 2-2-3 4-1-1 9-1-1. I cannot get into the device using the serial port and entering ‘v’ at the appropriate time. Am I correct in thinking that I am now the proud owner of a small black brick?

The second unit worked fine for a couple of days, but then showed no activity whatsover on power up. It worked properly again the next day, but now is back to its inactive state. Another small black brick?

Finally, my objective is a ‘long serial cable’ for RAW data. I would be most grateful if somebody could let me know the commands to achieve this.

Many thanks

Would much appreciate some help!

What was the original POST and EOS revisions of these Portserver TS units? According to the release notes, you’d only need to update the POST if it was earlier than rev. 82000679_C1. Enhancements to the Web UI will also be detailed in the release notes for the 82000716 firmware.

As far as whether or not these units are still serviceable, these are Legacy units and most likely no longer under warranty, but you can check status by serial number here to determine: http://www.digi.com/support/status.jsp?status=1

Regarding your application, any of the Portserver TS units would be capable of this type of application, using either the TCP Sockets or Serial Tunneling profiles of the WebUI, with correct configuration of IP address and TCP port to connect to.

Thanks very much for your help. The PS TS4s do indeed have POST rev 820000679_C1, and the firmware is updated to 820000716_L1. This works perfectly on one unit and sometimes on the second - but the GUI is totally different from that in the man pages.

I have just purchased an almost new PS TS8 so I will set that up for Serial Tunneling and see what that looks like on the CLI. Then I can hopefully produce the same results on one of the TS4 units.