PortServer TS 4 dead after POST upgrade

  1. Went to digi.com and selected “PortServer TS 1/2/4”->Firmware Upgrade
  2. Note says “you MUST upgrade to POST 82000751_D or higher”

#> show versions

PortServer TS 4(55000629-03):

Component Part-Number Release-Tag

BOOT 82000689 release_82000697_B
POST 82000679 release_82000679_D
Factory EOS 82000716 release_82000716_L
Running EOS 82000716 release_82000716_L

  1. Downloaded 82000751_D.bin from web site
  2. Executed the update procedure:

#> boot load-boot=
Downloading 82000751_D.bin
DErasing Flash.
Storing into Flash.
DStoring into Flash.
Storing into Flash.
Download complete.
Verifying image in flash.

Firmware appears valid and will be run on next boot.

  1. Rebooted the PortServer
    #> boot action=reset

  2. Power LED blinked 1-1-1 and stayed off and device no longer responds on network.

  3. Held reset and applied power to set factory defaults. Power LED blinked 1-5-1. Released reset and LED blinks 1-1-1 and goes back off.

  4. Tried hardware diagnostics by setting 9600-8-N-1 on port 1 followed by holding in reset, applying power, and pressing ‘v’. The menu does not appear. Tried this many, many times.

Any ideas?

The 82000751_D.bin image is for a different hardware model. It appears to have corrupted the image on the unit. If you are unable to recover the unit using the diagnostic “v” mode, you will want to pursue an RMA (repair) with Digi International Tech. Support.

I figured out how to get into diagnostics mode. BTW, the instructions on the web site are wrong (http://www.digi.com/support/kbase/kbaseresultdetl.jsp?id=931). Do not hold down the reset button on power up. Instead wait until the first blink of the power light and then hold down reset and press ‘v’.

Once I booted into user diagnostics, there is no option to update the POST. Option C is “Restore OS from a TFTP server.”. I tried this with the POST image and it is rejected:

---------------------------- User Diagnostics ----------------------------

m) Quick memory test (seconds). M) Long memory test (minutes).
h) ->Hardware diagnostic tests. V) Show VPD data.
2) boot action=eewrite. 3) boot action=factory.
C) Restore OS from a TFTP server. P) Set PORT1 to 9600,8N1.

100UH Enter choice (ESC to exit-User Diagnostics)[mMhV23CP] :C

Settings initialized

Enter TFTP filename []: 82000679_D.bin
Enter IP address []:
Enter network mask []:
Enter network gateway []:
Enter network TFTP server []:

TFTP filename : 82000679_D.bin
IP address :
network mask :
network gateway :
network TFTP server:

Enter ‘y’ to accept TFTP settings, ‘n’ to change the settings: y
Working, please wait …
TFTP() returned 131072 bytes

Error… wrong EOS image from download!

Is there a way to update the POST from diagnostics?

As shown in my previous post, I am already at the latest EOS image for this unit, 82000716_L. Just for chagrins, I went ahead and did an upgrade to that image with the diagnostics. The unit still does not respond. The power LED blinks 5-10 randomly and then stays out. The unit never sends out a DHCP discover nor does it respond to the static ARP initialization.

The problem I have is that:

  1. I went to the Digi web site and selected Support->PortServer TS 4->Firmware
  2. The web site says “For a wired device server (Digi One TS, PortServer TS 2/4, etc.), you MUST upgrade to POST 82000751_D or higher”
  3. There is NO mention of hardware revision dependencies in the web site or in the release notes.
  4. I apply said POST image (82000751_D) as instructed.
  5. My unit no longer functions.
  6. Apparently, there is no way to recover.

No, it is not possible to update the POST image here. You will however, want to update the firmware image in hopes it will recover the unit.

At this point, repair arrangements should be made for this unit.