Power Cycle Dialog Error Message

Hi there,

I recently purchased the XBee Pro programmable dev kit (XBP24-BZ7B-DK). I followed the getting started instructions found in the document titled “Getting Started Guide - XBee-PRO® ZB Programmable Development Kit”.

I was able to get all the devices recognized by windows. However, I was not able to load the boot loader into the module.

Whenever I “run” the program, an error window “Power Cycle Dialog” pops up.

It says: “The target MCU is not responding. Please turn MCU power off…”

I tried to on and off the development board, debugger, etc, but the error message still pops up.

Does anyone know where the problem is?

Thank you for your help in advance!


I am developing and using Programmable XBee on CodeWarrior v6.3.
I regard CodeWarrior v10.1 as a procedure being the same.

Surely, development of Programmable XBee requires the cycle from Power OFF to Power ON, when it connects with USBMULTILINKBDM first.

A procedure is shown.

  1. Connect USBMULTILINKBDM to a target and PC.

  2. Turn on a target.

  3. Start debugger software on PC.

  4. Start connection between debugger and a target in the first dialog.

  5. It seems that the message of ON/OFF of POWER of a target comes out at this time.

  6. When the power supply of the target is supplied from USB, extract the cable of USB.

  7. Put the cable of USB.

  8. Since the Power ON/OFF cycle was completed now, click OK of a dialog.

  9. Since debugger software asks whether all the contents of FLASH ROM are eliminated, OK.

  10. After the target has finally running, debugger starts.

Is this procedure in agreement with your procedure?


Thanks for your reply!

Yes, I am following the procedure described by you. However, after i had OFF and ON the power to the development board by extracting and then attaching the USB cable, the same “Power Cycle Dialog” shows up again.

Could this be a hardware problem?

Hi shsh, did you solve this problem? If so, it would be nice to tell us how you managed it and what the problem was.

It’s normal to see that dialog but not continuously. I remember I had a similar problem but it was because the program was setting the XBee in Sleep Mode inmediatly after power-on, so I solved it pushing the commissioning button.
Does this only happen when trying to flash a bootloader or with any other example?

Another thing you may try is pushing reset button instead of power-on/off (sometimes, it works).

Hi, I’m having the same problem.

I have unstalled CW 10.1 and installed CW 6.3 but the same message appears. It ocurrs either in coordinator API or router API firmware. So, does not depend on the sleep mode…

Any other comment or advice will be very appreciated! Thank you!

Are you using the Programmable XBee Development Kit?

When launching the project in CW10.1, what do you see in the Console view? Is it something like this?

Info: Windows NT detected.
Info: USB HCS08/HCS12 MULTILINK detected - Flash Version 5.84
Info: Frequency change to ~0hz.
Info: Frequency change to ~0hz.
Info: Frequency change to ~0hz.
Info: Frequency change to ~0hz.
Info: Frequency change to ~0hz.
Info: Frequency change to ~0hz.
Info: Frequency change to ~0hz.
Info: Frequency change to ~0hz.
Error: Can not enter background mode.
Info: Frequency change to ~0hz.
Info: Frequency change to ~0hz.
Info: Unable to initialize PEDebug.


Hello Diegoe,

Yes, I am using the Programmable XBee Dev Kit. And you are right, that is exactly what I see in the Console view.

Any comments?
Thank you in advance

Have you checked the debugger is correctly attached to the XBee Interface Board? The red cable of the ribbon cable corresponds to the Pin 1 of the debug connector.

If it is correctly attached, could you post the part number of your XBee module? You will find it in the back side stick of the module. It should start with XBP24

Anyway, the kit cames with 2 programmable XBee modules. Have you verified if the other module works?


Hello, thank you for the reply.

Yes the module is XBP24BZ.

The debugger should be correctly attached as the blue and yellow leds light when power is applied to the debugger and the module respectively.

The module seems to be OK as it responds to normal AT or API commands.


Have you tried with the other Programmable XBee module of the Kit? Does it work?

If you open a serial connection (9600, 8-n-1 None) with the module, do you see the bootloader menu? It is something like this:

F-Update App
V-BL Ver.
A-App Ver.


Actually, I have a DigiMesh kit, and also I bought a programable ZigBee module XBP24. As the interface boards are the same, I use one of the boards with the programable module. As I only have one programable module I could not try the second. However, I will receive today another 2 new modules, so I can test these also.
In ever case, following the instructions to access the bootloaeder (using RTS and Break lines) I never get the expected console menu as you posted, but only three lines:

.EM250 Bootloader. v20 b09
.1. upload ebl
.2. run
.3. ebl info
.BL > .

When trying to upload a binary file using XModem, the file starts to upload but never ends to upload.


That is the bootloader of the radio chip, it seems you are not able to communicate with the programmable chip of the XBee module for any reason. It could be a hardware problem.

Anyway, just to verify your module is programmable, could you post its part number? but the complete number. I.E.:



Thank you for your time and advice.

I will try with the new modules as soon as I got them.

This is what it is writed at the back side:


Do you have any aditional coment?
Best regards

Hello Eloy,

I need to verify it, but I am afraid that part number does not correspond with a programmable XBee module.

I have here a couple of XBee modules with the following part number XBP24BZ7WIT-, and none of them are programmable. The programmable version of that module has this part number: XBP24BZ7WITB (notice the B). I think in your case it should be XBP24BZ7UITB, but I am not sure.


Hello Diego,

I’m almost sure you are right, this code seems to be for a non programmable module. The last letter should be a ‘B’. When I bought the module, I just look at the final numbers to be ‘003’ and not ‘004’.

Well, I should buy the correct ones…

Thank you in any case for your help!


You require making contact with and obtaining help from service provider, just calling them they will fix it. This message generally happens when you attempt to connect to the internet. The error come into view and the connection fails. Your hard drive is dreadful. You’ll have to obtain a new one.