Programming Xbee-PRO

Hi everyone,

I’m having a bit of trouble here with a XBee Pro S2… I hope someone can help!

I’ve got a breadboard setup which has a steady 3v3 supply, a MAX232 and a 74HC14 inverting schmitt trigger for the DTR and RTS lines. It’s connected to a “real” (i.e. on the motherboard) serial port on a Windows 7 box with X-CTU, although I have also tried an XP machine.

I have been able to program several Series 1 (XB24-AWI-001) modules and a couple of Series 2 (XBP24-BSIT-004) modules with it. However, I don’t seem to be getting any joy with the Series 2 module with a wire antenna (XBP24-BWIT-004 revG).

I’ve tried all sorts of stuff that I found online - removing the module and plugging it in when X-CTU pops up the error window, etc, and I can’t get a peep out of the thing. I also can’t raise the bootloader via the terminal either.

EDIT: the “assoc” LED I’ve got hooked up is flashing. So it’s not TOTALLY dead …

But the thing is brand new! Otherwise I probably would have put it down to “something stupid” I did to kill the module. Has anyone got any tips? For either reviving it, or returning broken stuff to Digi?!

thanks and have a nice weekend!


Have you checked your board schematic with the XBIB-R-Dev Board schematic available on