Power will not stay on - PortServer TS1

We just purchased a hardened TS 1 - I’ve got a possible power issue.
When I connect the power (12Vdc 500ma), the PWR READY lights flash then go out and immediately the LINK ACT lights flash then go out - then there are no lights on. When I disconnect the power and reconnect, the same thing happens again. I thought it may be overcurrent protection so I tried a 9Vdc 300ma - same thing happens so I figured maybe it’s undercurrent, so I tried a 13Vdc 1000ma and the same thing happened.
Could we have a defective unit? Or am I missing something??
It would be nice to get some real support on a brand new unit.
Thank you for any help!

According to the specifications, 12VDC 500mA should work:


Are you using a Digi provided power supply?

It is possible the unit is defective, you should reach out to Digi Tech. Support to determine whether an RMA is needed.

Thanks for the reply! I wanted to reach out to Digi tech support, but I can’t find a link anywhere to ask a question without paying!
I am not using a digi power supply, but I have several extra supplies that fall within the rated vdc/current range and none seem to work.
Thanks again!

Ah ha! Just FYI - It’s totally my bad. (I hate that saying) anyway - it takes almost 60 seconds for the port server to boot up. If I had had an Ethernet cable plugged in during power-up, I would of seen activity. Without it, the power light will not come on until unit is fully active. I didn’t find this in the documentation, so I apologize.
Thank you!