Problem with pairing device.

Hi,
I try to pairing Router with Coordinator and I had problem with that, for last week. I would first write some information, so let’s start:

  1. Board type: Digi XBee S2C (XB24C…, 004-revB, 0013A200…)

  2. HARDWARE_VERSION - 0x2242

  3. LONG_VERSION:
    .Xbee-Regular S2C BETA ver: 4016
    .Build: Aug 19 2010 19:42:59
    .EZNet stack ver: 4253
    .HW Ver: 22423030
    .Bootloader ver: 4253

  4. FIRMWARE_VERSION - 0x4016

  5. Coordinator settings (AT command list)
    +++
    ATCE 1 // SET CE to 1 for coordinator
    ATSM 0 // SET SM to 0 for coordinator
    ATWR // Write to memory
    ATAC // Apply change (prophylactic)
    ATID “F1213…” // Set Extended PAN ID
    ATDL “FFFF” // Destination Address Low
    ATZS 1 // ZigBee profile
    ATSD 2 // Scan duration
    ATAC // Apply change (prophylactic)
    ATCT C8 // Command timeout
    ATEO 1 // Encryption Options
    ATNK “F123…” // Network Encryption Key
    ATKY 0 // Link key
    ATEE 1 // Encription Enable
    ATNJ “FF” // Node join time (FF means - all the time)
    ATDH “0000” // Destination Address High
    ATAC // Apply change (prophylactic)
    ATNR 0 // Without this command coordinator wont start
    ATAI // Check status, all is ok, coordinator start, result = 0
    ATAP 1 // Api mode enable - but when I try to send API frame I dont get response…

  6. Router settings (AT command list)
    +++
    ATCE 0 // SET CE to 1 for coordinator
    ATSM 0 // SET SM to 0 for coordinator
    ATWR // Write to memory
    ATAC // Apply change (prophylactic)
    ATID “F1213…” // Set Extended PAN ID or set to “0” to join to random network
    ATDL “0000” // Destination Address Low - “0000” for coordinator address
    ATZS 1 // ZigBee profile
    ATSD 2 // Scan duration
    ATAC // Apply change (prophylactic)
    ATCT C8 // Command timeout
    // ATEO 1 // Encryption Options
    // ATNK “F123…” // Network Encryption Key
    // ATKY 0 // Link key
    // ATEE 1 // Encription Enable
    ATNJ “FF” // Node join time (FF means - all the time)
    ATDH “0000” // Destination Address High
    ATAC // Apply change (prophylactic)
    // ATNR 0 // Without this command coordinator wont start
    ATAI // Check status, all is ok, coordinator start, result = 0
    ATAP 1 // Api mode enable - but when I try to send API frame I dont get response…
    ATCB4 // COMISSIONING_BUTTON_4CLICK

This is my last configuration, but I try a lot of combination, mayby somebody know why this isn’t work.
What should I do to pairing router with coordinator?
To make this PAN works.
Greetings,

Hi,
at first I would ask You about configuration accept-start, if I use ATAC command, device should accept configuration with immediate starting? Too use them or I always need to restart network or device?

Second, I use ATZS 1 but I think about ATZS 2 (I need mesh network with ZigBee PRO profile it willbe ATZS 2?), unless XBee S2C doesn’t have this possibility?

My current configuration:

for coordinator:
+++ -> ATCE 1 -> ATSM 0 -> ATAC -> ATID “0123F321” -> ATSC “F” -> ATSD “4” -> ATZS “0” -> ATCT “C8” -> ATNJ “FF” -> ATAC -> ATWR -> ATNR “0” (for network reset) -> ATAI (to check coordinator status = all is ok, network has started) -> ATAP “1” (API mode enable) -> ATCN

for router:
+++ -> ATCE 0 -> ATSM 0 -> ATAC -> ATID “0123F321” -> ATSC “F” -> ATSD “4” -> ATZS “0” -> ATCT “C8” -> ATNJ “FF” -> ATAC -> ATWR -> ATAI (to check router status = fail, router doesn’t connect to coordinator) -> ATAP “1” (API mode enable) -> ATCN

This configuration has disabled encryption, but device wont pairing.

5 minutes ago i try to connect devices without any configured options all goes default after the ID and CE/SM.

Greetings,