Problems setting up Etherlite 80

I am attempting to set up an Etherlite 80 with my Ubuntu 8.04 machine. Two problems:

  1. I ran the installer with the GUI, and I’m pretty sure it worked, but when I attempt to re-run it in GUI mode, it just flashes a window and doesn’t do anything, and when I do it in no-GUI mode, I get this output:

Files for EtherLite - RealPort on Linux:
drivers/linux/realport/40002086_K.src.rpm
drivers/linux/realport/40002086_K.tgz
notes/93000359_K.txt
Would you like to run the install script? (y/n):y
[: 32: Illegal number:

specific/sh_scripts/linux_installer: 384: rpm: not found
Installing the RPM…
specific/sh_scripts/linux_installer: 384: rpmbuild: not found
B_TAR=‘false’
COLORTERM=‘gnome-terminal’
CUR_VER=‘’
DISPLAY=‘’
DIST=‘unsupported’
GUI=‘NOGUI’
HOME=‘/home/ayoshitake’
IFS=’

LANG=‘en_US.UTF-8’
LD_LIBRARY_PATH=‘./tcl-tk/linux-intel/lib:’
LOGFILEB=‘/tmp/digicd_build.log’
LOGFILEI=‘/tmp/digicd_install.log’
LOGFILETEMP=‘/tmp/temp’
LOGNAME=‘root’
LS_COLORS=‘no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:.tar=01;31:.tgz=01;31:.svgz=01;31:.arj=01;31:.taz=01;31:.lzh=01;31:.lzma=01;31:.zip=01;31:.z=01;31:.Z=01;31:.dz=01;31:.gz=01;31:.bz2=01;31:.bz=01;31:.tbz2=01;31:.tz=01;31:.deb=01;31:.rpm=01;31:.jar=01;31:.rar=01;31:.ace=01;31:.zoo=01;31:.cpio=01;31:.7z=01;31:.rz=01;31:.jpg=01;35:.jpeg=01;35:.gif=01;35:.bmp=01;35:.pbm=01;35:.pgm=01;35:.ppm=01;35:.tga=01;35:.xbm=01;35:.xpm=01;35:.tif=01;35:.tiff=01;35:.png=01;35:.svg=01;35:.mng=01;35:.pcx=01;35:.mov=01;35:.mpg=01;35:.mpeg=01;35:.m2v=01;35:.mkv=01;35:.ogm=01;35:.mp4=01;35:.m4v=01;35:.mp4v=01;35:.vob=01;35:.qt=01;35:.nuv=01;35:.wmv=01;35:.asf=01;35:.rm=01;35:.rmvb=01;35:.flc=01;35:.avi=01;35:.fli=01;35:.gl=01;35:.dl=01;35:.xcf=01;35:.xwd=01;35:.yuv=01;35:.aac=00;36:.au=00;36:.flac=00;36:.mid=00;36:.midi=00;36:.mka=00;36:.mp3=00;36:.mpc=00;36:.ogg=00;36:.ra=00;36:.wav=00;36:’
OLDPWD=‘/media/cdrom0’
OPTIND=‘1’
PATH=‘/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin:/usr/bin/X11:/usr/openwin/bin:/usr/X/bin:/usr/dt/bin’
PKG=‘drivers/linux/realport/40002086_K.src.rpm’
PPID=‘22656’
PROD=‘etherrp’
PS1=‘# ’
PS2=’> ’
PS4=‘+ ’
PWD=’/media/cdrom0’
RPMBUILD=‘rpmbuild’
RPMINSTALL=‘rpm -ihvv’
SHELL=‘/bin/bash’
SOFT=‘rp’
SUDO_COMMAND=‘./setup -nogui’
SUDO_GID=‘1000’
SUDO_UID=‘1000’
SUDO_USER=‘ayoshitake’
TERM=‘xterm’
USER=‘root’
USERNAME=‘root’
XAUTHORITY=‘/home/ayoshitake/.Xauthority’

ERROR: RPM file not written. See /tmp/digicd_build.log
for build error messages.
[: 384: ==: unexpected operator
[: 384: ==: unexpected operator

Location of installation files:
drivers/linux/realport

Press to continue…
read: 384: Illegal option -s

Is this just because I’ve installed the drivers already, or is there a bigger problem here?

  1. I cannot find dgipserv on the CD given, except a Windows version of it (dgipserv.exe). Is this downloadable elsewhere, or is it just missing because the driver installation didn’t work properly?

Thanks for all help,
Aaron

I recommend downloading the latest driver from the web-site:

http://www.digi.com/support/productdetl.jsp?pid=2010&osvid=146&tp=1&s=0

Install steps:

http://www.digi.com/support/kbase/kbaseresultdetl.jsp?id=3052

Also, it appears you may not have rpm or rpm-build installed on your Linux host. These will be required along with the following dependencies:

make, rpm-build, bash, gcc compiler, glibc-devel, kernel-source, kernel-headers, ncurses-devel, perl, and tcsh.