put rom.bin onto module

Hi Forum,

i’m using a wi-me -c device with the developer board. i have loaded the ftp server file system sample with the jtag debugger, put the rom.bin and the image.bin to the device via ftp an rebootet. Instead of the bootup screen on serial port the device just send some “CCCCC…” out Settings on serial port are correct. After setting some breakpoints to the ftp server application it turned out that the NAFlashWrite() methods in naftpapp.c are never called. In Line 224 of naftpapp.c starts a while loop with

while (currentLength == BUFFERSIZE)…

where the currentLength is something like 8296 while BUFFERSIZE is 131072. Maybe there should be an

while (currentLength <= BUFFERSIZE)…

to get some buffer written to flash?

Need more coffee!

Problem solved. As listed in troubleshooting section in Programmers Guid i did following steps:

  1. start with ftp server application
  2. put rom.bin in binary mode into module
  3. restart module with ftp server application
  4. put image.bin in binary mode
  5. restart, smile and get another cup of coffee


Thank you very much for your post. I was following the instruction in the Digi ESP Help and was not able to recover a device with a not valid rom image. I used a JTAG emulator to execute a program with FTP service enabled and I uploaded the rom.bin and image.bin files in binary mode, as it says in the help file. But that does not work.

After reading your post, I uploaded only the rom.bin file, reset the module and then uploaded the image.bin file. This way it finally worked.

Thank you again,