Unable to run naftpapp - flash fail (NetOS 6.3)

Hi folks,

I’ve just restarted some ConnectCore9C development, and have run into some problem when running naftpapp standalone, or if integrated in my own application:

This is part of the console output I get:
Network IP configured.
FTP Server not started
Unable to get Flash sector size
Check if flash is enabled

I then tried to do a complete reset by shorting pin 1+4 on P1 and running naftpapp according to instructions elsewhere on this support forum (two-step reload of ROM.BIN and IMAGE.BIN via FTP).

Unfortunately even after running the P1-shorting and loading clean naftpapp from debugger, I get the same flash error message when running naftpapp, and I’m never able to ftp put the ROM.BIN and IMAGE.BIN files.

However I know the flash is working because if I start the module without debugger and without shorting P1 pins, my flash-stored application loads just fine (except that the embedded ftp-part is also failing here, with same error message)

NOTE1: Exact same reset/reload procedure, with exact same IMAGE.BIN and ROM.BIN works 100% OK on other boards.

NOTE2: The failing board was working just fine before uploding a image.bin with my application. I think the current combination of ROM.BIN and IMAGE.BIN saved on the board now is some bad combination, that this is the reason (and then that P1 full reset would fix this problem…)

Now, instead I try with TFTPD32, and load image.bin for either myapp or naftpapp, the image is loaded to the controller, it waits some time, and then it seems to reset and load the old flash image again.

Any idea how I can recover this bad behaving 9C board???

Thanx for any help I can get,