Help: seems unable to write into the digi connectME flash

Dear All,

I am a beginner in this area, so …

I have this new Connect ME Development Kit and a digi ConnectME with JTAG.

I have tried to compile(gnu and cygwin) some examples in NetOS 6.3 and run it thru the Raven and gdbtk debuger. Everything works.

Now I want to burn the original factory-defaults image back into the connectME and don’t have the luck.

I followed the instruction on the “NET+Works with GNU Tools Programmer’s Guide” regarding “Restoring the contents of flash ROM”(page 74). I make the rom.bin in bsp/platforms/connectme and use the naftpapp(The ram based ftp server) to burn the rom.bin into the flash first. The ftp client complains nothing but the hyperterminal responds “ftp_flash_stor NAFlashWrite() error -2.” when I quit the ftp client. Well, then I thought I could just ignore it and restart the naftpapp and burn the image.bin of naftpapp, the ftp client complains this time and the Hyperterminal show the “ftp_flash_stor NAFlashWrite() error -2.” again. Following is a snip of my ftp client screen…

$ ftp
Connected to
220 NET+OS 6.3 FTP server ready.
Name ( (none)
230 User (none) logged in.
Remote system type is NAFTPAPP.
ftp> bin
200 Type set to I.
ftp> put image.bin
200 PORT command Ok.
150 About to open data connection.
ftp: netout: Connection reset by peer
552 Requested file action aborted. Exceeded storage allocation.

I checked the naftpapp.c source code and found the Hyperterminal error is a result of NAFlashWrite().

Can you experts give me a hint on how to solve this problem? Thanks.



What is the part number of this ME module you have? The part number is printed on the label.

In order to successfully be able to use NET+OS 6.3 you need to have one of our -C ME Modules, with a part number of either 50000878-03 or 50000878-04.

The original ME modules, with part number 50000866 and -S modules, with part number 50000878-01 are not compatible with NET+OS 6.3.

Based on the flash error you are seeing I assume that you do not have a 50000878-03 or -04 module.


Hi, Cameron,

You are right. The part number is PN: (1P)50000866-02 E. Is there a way to make it work? Like change the flash sector number, etc. Can you at least give me some hint regarding how to write the fatory-default digi connectMe image (and post?) into the sector.

Can you direct me to a web page regarding why the 50000866 cannot be working with NET+OS6.3 ? Is this 50000866 a -S model and the new NET+OS6.3 needs a -C model?

Thank you very much.


Message was edited by: henrichen

Dear Cameron,

I modified the naftpapp example to “burn” post.bin into sector 5 and image.bin to sector 7 (256k) and the factory-default was restored into the digi-connectME without problem now.

I tried to do “upgrade firmware” with an example image (naftpapp/32b/image.bin) via the digi-connectME’s default webpage interface http://ip-address/admin/upgrade_firmware.htm

but the web complains “Unable to update firmware: Invalid image header”. Would you please hint me about how to make an example image with VALID image header?

Sincerely yours,