Range problem with Xbee Digi-mesh 2.4

Hi Everyone.

We have just purchased a half dozen x-bees (pros with RPSMA adapter) and are creating a digimesh network. I am totally new to this and am finding it quite difficult to set the whole system up.

At any rate, one of our x-bees seems not to be working - it only has a range of about 15 feet, indoors. (!) I may have ran 5 volts through the x-bee by mistake, is that enough to damage the unit such that it still functions but in this diminished way? I have checked (and double checked) all the connections and they seem to be fine. Is there some setting I am overlooking?

I am very impressed with the support available on this forum. I have worked very hard at figuring out the x-bee system, but unfortunately have several more questions to ask.

This one will do for now. Thanks in advance for your help!

RPSMA refers to a separate plug-in antenna, I think (please correct me if I’m wrong). Maybe the antenna is making bad contact - have you tried swapping antennas around to see whether the problem moves with the antenna?

I don’t know whether 5V would damage the chip, though I’d be surprised if the result of damage was just to reduce the power. You could try asking the kind folks at Digi support - they must have encountered that situation!

The only setting that should be relevant to range is the PL (Power Level) setting. I imagine you’ve checked that. Oops - see next paragraph.

Hmm. That’s interesting. I just looked at the DigiMesh product manual, and the PL command isn’t documented as far as I can see. Yet on page 5 of the manual it does refer to the PL command. Is it just me, or has that explanation been left out?

Otherwise, a bit more information would help. If it might be a settings problem, then posting the settings on the “bad” chip and a “good” one would make things clearer. Best way (for me at least) is to use X-CTU to save the settings as .pro files, and attach or paste them to the posting.

Also a couple of standard questions: what version of firmware is running (ATVR command), and what are the hardware versions (ATHV command)? (The firmware version will be visible in the .pro file, but the hardware version won’t.)

Now the bad news: I’m encouraging you to provide all this information, but I’m about to be away from the net for a few days so from me you won’t get an immediate answer. But others might also find the information helpful, so you may get more responses in the meantime.

The radios are failry hearty, and I’ve seent hem take 5V and still operate properly, but voltage above the specified 3.6V max can definitely damamge the radio, so that has to always be a possiblity.

The RPSMA is indeed the antenna connection. It has the threaded connection.

The PL command is available to be set in the radio, even if it somehow isn’t listed in the product manual. That is simply an oversight in the manual.

If loaded with default settings (can be done by merely clicking the Restore button), all radios will dafault to the same ID same channel, and all radios will be set to broadcast transmission (DH = 0 and DL set to FFFF). This will allow all radios to communicate with each other at default settings. Once your network becomes larger, broadcasting information isn’t the most efficient method of communcation, but it shoud suffice for smaller netowrks and for testing.

Hello John,

Many thanks for your speedy reply. I will check out the PL setting (never heard of it till now). A fellow poster below says the absence of the PL command in the manual is probably an oversight in the manual, and the PL command should exist for Digimesh.

The problem with the xbees has gotten weird I must say. I have restored default settings on 4 of the 6 x-bees, and played around with different ones on the receiving end, and in every case the range is the same - about 10 feet indoors.

I did check the firmware version, and it is 8003, but the hardware version I am unsure of. (The whole system is unfortunately quite a long distance from this computer which has inter-net access - and I can only get to it once a day)

Anyhow, I will try to get that .pro file to you and post it tomorrow (or later today if I have a chance). As for the hardware version, I will hunt it down for you.

Once again, I want to thank you for your time. I am in no particular rush for this and simply appreciate the help. Same goes for everyone else on this forum.

Thank-you for your post. It is good to know that the xbees are “hearty”. Now all my xbees (that I’ve tested so far 4 out of 6) have the same problem and I am quite at a loss. I am pretty certain that I didn’t run 5 volts through all of them, and since they are all behaving in the same way, it does seem highly unlikely to be caused from a 5v bolt of energy that I may have sent them.

One thing that may be relevant is that 2 of the xbees are xbpro24 with originally 802.15.4 protocol, but then I downloaded the firmware for the digimesh 2.4. I know that is not what those models usually work with, but it said on the websight that digimesh was supported with those units.

At any rate, the problem I am having now is not limited to just those two (which have a little wire antenna on it) but exists with the RPMSA antenna and with the chip antenna.

What is going on?

Anyhow, I will keep working on this and I appreciate your willingness to offer ideas.

Be well,



Just wondering. are your chips printed with “Digi” or “Maxstream” ?

I found out that Digimesh 2.4 will NOT work with older chips imprinted with “Maxstream”…

SOmething to do with the internal circuitry. Digi added something when they took over.

I have maxstream chips from year 2007 amd they are working like they should.