Rapidport/4 failed/partially recieved fax

I have been having problems with incoming faxes since updgrading to Rapidport modems. All outgoing faxes send fine, but I see alot of the follwing in the server logs, and get alot of complaints from our clients about failed faxes. Our company sends 50-200 faxes a day and depends on responses being faxed back. This is starting to really impact our company.

Event Type: Error
Event Source: Microsoft Fax
Event Category: Inbound
Event ID: 32092
Date: 1/15/2009
Time: 9:46:26 AM
User: N/A
Computer: PICFAX
The Fax service failed to receive a fax. From: 208XXXXXXX. CallerId: . To: XXXXX. Pages: 0. Device Name: Rapidport USB 56K Modem PnP #8.

Event Type: Error
Event Source: Microsoft Fax
Event Category: Inbound
Event ID: 32034
Date: 1/15/2009
Time: 9:22:04 AM
User: N/A
Computer: PICFAX
An incoming fax could not be received due to a reception error. Only part of the incoming fax was received. Contact the sender and request that the fax be resent. File Name: C:\Documents and Settings\All Users\Application Data\Microsoft\Windows NT\MSFax\Queue\1C97735719964.tif. From: . CallerId: . To: XXXXXXX. Recovered Pages: 1. Total Pages: 2. Transmission time: 0:02:26. Device Name: Rapidport USB 56K Modem PnP #9.

Last weekend I tried upgrading from the 4.5 drivers to the 5.0 drivers. Not only did this not fix the problem, it slowly got worse until yesterday about half of our incoming faxes were failing. I decided to roll back to the 4.5 drivers which put us back to the old failure rate of approximatly %20 of incoming faxes having issues.

Before rolling back the drivers I tried:
Turning off compression (No effect)
Dropping port speed on all modems one step at a time until all modems were set at 9600 (No effect)

This is my setup.
Dell Poweredge 860 server
Windows 2K3 Enterprise SP2 All patches/updates installed
3 Rapidport/4 modems running version 4.5 drivers
PN: (1p)50001241-01 K
PN: (1p)50001241-02 A
PN: (1p)50001241-02 A
The following is the same for all modems:
ATI3 - LT V.90 1.0 Rapidport USB Data/Fax Modem Version 4.25f
All modems set to a port speed of 38400

Microsoft claims it is a problem with time out values of the T30 Protocol and the only way to fix it is to buy new modems.

Oops, please ignore this.

We have newer firmware for that one “revision K” Rapidport. Supposedly it better supports faxing applications so I suggest updating the firmware on that unit.

See the .hex file I’ve attached and be sure to only update the rev K unit. To be safe, if feasible, unplug the other two units from the PC before doing the firmware update. I also recommend first disabling whatever applications might be using the modems (i.e. MS Fax in your scenario) and then power cycling the rev K unit before updating the firmware.

That’s the ideal way to do it, at least. It looks like your units are in a production environment so you may need to do it a different way, i.e. leave the other two units connected. In that case, just be sure that you’re working with the correct (rev K) Rapidport, because this firmware is ONLY compatible with rev K units.

Once you’re ready to update the firmware, open the Edgeport Configuration Utility from the start menu (should be in the “Digi USB” group), click the Update button and browse to the gqqg132j.hex file. After you update that Rapidport, confirm that you’re running the newer version by querying for the firmware like you previously did. It should repond with something other than 4.25f. I think the one I attached is 1.32j.

Then, of course, let me know again how the behavior changes. What I’d be hoping to see is a lower rate of failures overall but still some failures associated with the other two units. And if that ends up happening then we can try to get those other two units swapped with newer rev K ones w/ the newer firmware.

After a few days of testing I can see a definite improvement with the Rev K modem. It’s still not perfect, but much improved.
The Rev A modems are still showing a pretty high incoming failure rate. (10-20%)

I have updated the Rev K modem to firmware 1.32j. Amazingly, nobody screamed when I took down the fax services, so I’ll take that as a good omen.
The Rev K modem hosts 2 of our main lines and the Rev A’s host rollovers for those lines. Hopefully by the end of the day I should be able to gather enough data to do some trend reporting on these.


One thing I did note right away was that the time it took to query the updated modems was much, much shorter than before. (5-10 seconds VS 30-50 seconds)

I just recieved one of the replacement modems. According to your post I was supposed to recieve one of the newer “revision K” units, but I was shipped a rev. A model.
PN:(1P)50001241-02 A
My question is: Am I going to have the same problems with this new rev A modem that I did with the last ones?

The unit you received (-02 A) is equivalent to the rev K that I asked to be sent to you. It’s easy to get it confused with -01 A (I did at first!) but don’t. They are different.

So, let me know how the -02 A behaves.

I was able to update the 02 A modem that I already have in service to 1.32j. So far it seems to be working.
When I went to install the new modem I realized that your company shipped me a modem and nothing else. No power cable, no USB cable, no driver software, nothing. Just a box with the modem inside. The modem I sent you was sent in it’s original packaging, with a manual, a driver cd, and both cables.

OK, glad to hear that.

I suppose I should have made it clear that you only needed to ship your Rapidport to us (no power adapter, etc.).

We can send you some of these things if needed. What would you like? Presumably a power cable. USB cable, anything else?

Power and USB please.

OK, I requested for two USB cables and power supplies to be shipped to you. This presumes that the other replacement unit will also be just the unit by itself, and that you also included the USB cable and power supply with the other unit you shipped us.

Hopefully the latest firmware and hardware will do the trick. Keep me updated.

FYI I did not ship the other unit. I was waiting until I had the first one in production before I sent the second one. If it is a firmware issue then I don’t see any reason to send you the second one if you guys are going to just send back another modem that is the exact same model.

I think I need to stop presuming so much =)

OK, I’ll ask our order management folks to cancel the RMA request for that other/second unit. You’ll probably end up with an extra USB cable and power supply.

Please remind me what the S/N is of the unit that you still have (the second one that you didn’t ship).

The one that is not being sent back is:
SN: (S)W83503510

OK, glad to hear that.

Please either add your e-mail address to your profile or make it “visible” and I’ll have someone contact you to try to arrange swapping the Rev A units for newer Rev K units. Also let me know where you’re located geographically.

I have made my address visible. We are in Washington state.