RCM4300 FAT Support for MiniSD Memory

Hello All,

Has anyone purchased the RCM4300 and tried to use the onboard Mini-SD module with the purchased FAT add-on? I am using Dynamic-C V10.21 and FAT V2.13 (These are the latest versions). There are only a few sample programs available to use and they don’t seem to be updated to work with this core module and V2.13 of the FAT add-on. The Fat Release Notes for V2.13 indicates that support for the SD card was just added, so maybe no one has tested this yet. Tech Note TN252 says that only certain cards will work. There is one flash program included in the RCM4300\SD_Flash area called SDFLASH_INSPECT. This program works just fine. Any of the 10 or so FAT programs all fail sooner or later. The most common error is: fat_AutoMount() error (-38) Function not implemented.

Can someone at ZWorld upload a simple FAT program that has been tested with the RCM4300 and the latest FAT version that will: a) Initialize and format the card and then let us do some simple task?

I don’t understand why ZWorld releases a new core module like the RCM4300 that has advanced features like MCS Megabyte Code Support and an SD Card and then doesn’t give us a couple of very simple sample programs that show us that these features work. You would think that someone at ZWorld has a little program to at least test the hardware. I also don’t understand why I don’t see any other complaints in any of the forums on these features. Sometimes I feel like I am the only one trying to use these products to do more than flast LEDs…

All FAT 2.13 samples do work with the RCM4300 and were tested on SD cards. If you are having difficulty getting your system working properly, you should contact technical support.

Can anyone post the file SDFLASH_INSPECT.C please?


This file is included in the DC 10.21 release. This can be downloaded at the following page on our website:

Download Page

You need DC 10.21 installed as the SDFLASH_INSPECT sample requires the SDFLASH.lib library which is also in the DC 10.21 release. This sample will not work on previous DC 10 versions as they do not have this library driver file.

I work with the RCM4310 using a miniSD, every time I need one miniSD is harder to find 1Gb or less…I wonder if Rabbit will do something to support the 2Gb o higher miniSD or microSD.


I have the same problem , we can find few 1 GB mini SD cards .

I know this is an old thread - but I had this problem and I found a slightly dodgy workaround to get my RCM4300 working with a 2Gb microSD (SanDisk) card… Using my PC - I’m not sure about other operating systems, but Windows 7 disk manager does not let you delete primary partitions from removable media… but if you go to the command prompt, use “diskpart” utility - then you can delete the primary partition, make a new 1GB (I actually did 1000Mb) partition, and then re-format to FAT16… and it seems to work fine (so far) in the RCM4300… WARNING: Be very careful not to accidentally delete your computers’ hard drive partitions when using “diskpart”!! It would be very easy to do!

UPDATE: The 2GB sandisk card worked ok for a few days, then it became corrupted - and I had to re-format… since then it corrupts itself every time I use it in the RCM4300…
So, maybe this isn’t such a good solution - or there could just be something wrong with my software!