RCM6650W WiFi Modbus

I am using a RCM6650W module and would like to poll modbus data via the WiFi. I am using Ad-Hoc mode and I can get the interface up and running with the ability to ping the WiFi.

However, when I try to attach a modbus master, it fails over WiFi. I have this same project working on a RCM6760 and can poll modbus data over the physical ethernet with no problem.

I have read where certain processes can only use the Primary Default IP, is Modbus TCP one of those items or should it work over WiFi as well?

How can I disable ETH0 and make the WiFi0 the default?

Any suggestions would be appreciated.

You can disable ethernet by putting the following in Project Options:


Thanks for the answer. Although this does help, I ended up having to set TCPCONFIG =0 and then manually configure the WiFi adapter settings. Modbus TCP worked fine over WiFi once I eliminated the other Ethernet port.