RCM6700 RFU issues

I’m currently using a RCM6700 (w/Dynamic C 10.72) in a system and as long as I compile directly to the target my program runs and all is fine. If I compile to a bin file and then use the RFU the program does not appear to run. I have verified that the RCM6700 is selected in Project Options->Targetless->Board Selection. Is there any other configuration option that I could be missing that could cause this? Any help would be greatly appreciated.

Hello, It seems like your module is in Programming mode. Once you uploaded the binary file on to the module, you should put your module is in RUN MODE by removing the jumpers from pins 1–2 on header JP1 on the Interface Board, the Rabbit 5000/6000 will operate in the Run Mode once the MiniCore is reset
For more information on Programming mode and Run mode, please go through the RCM6700 user’s manual at the below link

I hope this helps you.


Thanks for the response but it is in run mode and simply will not run. The RCM6700 is installed on our own circuit board which has a switch for program/run modes and the program will run after compiling directly to the target. I know it is not a run/program mode issue because I can power down (after compling to target), flip the switch back to run mode and then power up the board and the program runs fine. This is not the case when using the RFU. I use the same procedure, switch to program mode, load the bin using the RFU, power down, flip the switch to run mode and then power up. The program just does not run. To eliminate our circuit board from the equation I also tried programming the module on the development board that came with the development kit. I have the same issue. Any other suggestions?

Given that the program runs when executed directly from the IDE but fails with the RFU, have you tried disabling the debug kernel (project options\debugger\enable debug kernel) and removing the single step instructions (project options\compiler\advanced\debugging instructions and bios inclusion) to get the build in the IDE as close to the stand alone one?

This may help to show if there is a timing or code location issue which is effecting your application.

Also, have you tried one of the sample programs in the board with the RFU to see if they work?



I just downloaded the FlashLED02.c file to the RCM6700 with the RFU utility and it works fine.
I would download a fresh copy of the RFU 10.72 utility.

One other thing to verify is to make sure when you are Compiling the file to a .bin file option that you had selected the RCM6700 under Project Options. This is important to create the RCM6700 bin file.