Remotely connecting to the USBanywhere

Hi All

I am new to the field of networking and data logging so I apologise in advance for any ignorant questions!

I have recently purchased a USB anywhere/2 to enable me to connect remotely to USB data loggers I have on site. I have tested the USBanywhere at home and it works fine on my local subnet.

However, when I try to connect from a remote PC I cannot access or discover it. I am sure that it is because I am missing some basic know-how, but I have tried to follow the manual and still no joy.

Under the ‘discovery list’ of the remote PC I have put the IP address of my network, which is in the form 86.28.x.x is that the correct thing to do?

Where the USBanywhere is located it is connected to a router, I have read that this must be configured to forward subnet broadcasts. What exactly does this mean?

Do I have to adjust settings on the router to allow a remote PC to be able to connect?


If the AnywhereUSB is behind a router, and the host PC is elsewhere (not behind that same router) then you’ll need to setup a couple of “port forwards” on the router, to forward inbound traffic on ports 3422 UDP and 3422 TCP to the AnywhereUSB’s IP address. The AnywhereUSB should be configured with a static IP address in this scenario.

You would then input the router’s public / WAN IP address in the Discovery List, on the remote PC.

Does this help?


Thanks a lot for the reply. I have gone onto my host router’s settings and added two “port forwards”, both set at port 3422 for UDP and TCP, under the private port box I also left it at 3422 and for the destination IP I put, which is the static IP of the USBanywhere.

Unfortunately I still cannot connect using my public IP address on the remote pc. On my router settings I noticed a page on “routing”, where you input an IP, subnet mask and gateway. I tried to set this for the USBanywhere (in the hope to gain access) but it told me “invalid gateway” when I used the routers default gateway (

The AnywhereUSB needs to have a gateway IP address, which should be the router’s LAN IP address (I’m guessing Does that help?

The gateway IP address has already been set as the same as the LAN IP. Are there any other things I can try?

If you haven’t already, you might want to “undo” whatever changes you made related to the “routing” page that you described. Normally, the only thing you should have to do is simply add the two port forwards.

Please review the following KB article and let me know if it helps or not.

I have got it to work finally, thanks for all the help.

In the end what made it connect, was setting up a DMZ rule for the USBanywhere IP address on the router admin page