Requesting help with authentication of a SE network


I am seeking some help in establishing a Smart Energy network between a ConnectportX2 running as a coordinator and an XStick running as a router. I can get the devices up the the ‘Discover key establishment on trust center’ step on the flow chart concerning the joining logic for a SE network located on page 33 of the ‘Xbee/Xbee-PRO SE RF Modules’ document.

What I am getting at that stage is the Association Indication(AI) value on the XStick going to value 0x30 - Discovering Key Establishment Endpoint for a while during which the X2 receives two ‘Received device announce’ messages after which the XStick leaves the Zigbee network and indicates AI value 0x36 - Received terminate request.

I’d be really thankful for help on two points regarding this,

  1. What does Received terminate request actually mean? I think it means that something has timed out somewhere but I’m not sure and can’t find an details anywhere.
  2. Any idea’s on how to fix this? The two possibilities on the flow chart mentioned above are that the key establishment endpoint hasn’t been found or that key establishment has failed and there is different AI code for failing to find the key establishment endpoint.

Additional details

  • Both devices has test certificates installed.
  • Both devices have been given the same link key.
  • The XStick has firmware version 0x3319 the X2 has version

It seems as though either the CBKE or the link key exchange is failing.

Are there any messages seen coming from the gateway from idigi-se.appspot?

During the join of the X-Stick, was the add_device command run from the idigi-se.appspot Debug console right away?

Have you tried cutting and pasting the link-key from the example?


That was what I was thinking as well.

The only messages that are coming from the gateway via idigi-se.appspot are the two received device announce messages,

ZDO_Device_Manager - Received device announce message from known device 00:13:A2:00:40:66:6D:55 (NWK: 9201)

I ran the add_device command as close to the time when the X-Stick began transmitting as possible but this made no difference to the responses. I retried with the copy pasted link-key for both the XStick and the add_device message but again received the same result, two device announce messages from the gateway and an AI code of 0x36 on the XStick. The device does appear in the device information response after being added


And cheers for the reply man. I’m going to look into the key exchange process and see if that helps, if anyone else has an idea I’m all ears.

Further more changing the EO field to 0, disabling key exchange, results in the XStick connecting to the Zigbee network with no problems bar the lack of authentication.