Error 0x23

Hello There;

I’m currently trying to run the getting started guide for SE

I’ve been facing this problem for some time now:

0x23 - Valid Coordinator or Routers found, but they are not allowing joining (NJ expired)

Trying to connect an X-Stick Router SE to a CPX2-SE Coordinator with Production Certificate.
I’ve already uploaded a test certificate on the router, write certificate, set link key to ABCDEF1234567890, enable joining, Attempt to join network; still facing the same problem.

What am I doing that is not working?

Quest to solve by 20th of Jan. Hence, high Priority :frowning:

For some reason, I can’t even configure a Series 2 chip on SE firmware (3319) to join my SE coordinator. (tried using API packet creation method)
SE coordinator cannot detect another ZB in its network.

I suspect it has got to do with my configuration on my Coordinator SE that I may not have done. Not sure what though or the necessary requirements to enable network joining to happen.

Settings of my Coordinator is obtained via CLI as below:

state: on

aggregation (AR): 255 (x 10 sec)
broadcast_hops (BH): 0
discover_timeout (NT): 60 (x 100 msec)
encrypt_options (EO): 0x2 (bitfield)
ext_pan_id (ID): 0x0000000000000000
initial_pan_id (II): 0xffff
join_time (NJ): 254 (sec)
link_key (KY):
max_hops (NH): 30
network_key (NK):
power_level (PL): 4
power_mode (PM): 1
scan_channels (SC): 0x3fff (bitfield)
scan_duration (SD): 3 (exponent)
sleep_period (SP): 750 (x 10 msec)
pan_id (OI): 0x8885
ext_pan_id (OP): 0x9fd29a327718668d
channel (CH): 0x10
net_addr (MY): 0x0
association (AI): 0x0
firmware_version (VR): 0x3119
hardware_version (HV): 0x1a42
children (NC): 6
max_payload (NP): 128 (bytes)
verify_cert (VC): 1
stack_profile (ZS): 2

Looking above, it could be that KY parameter might be the problem. But when I type a 16 byte value; KY is still empty

#> set xbee link_key=0xabcdef1234567890

I guess it’s for security reasons the value is hidden. Can anybody verify?

This is getting rather confusing to operate an SE Network @_@



  1. Must set all Smart Energy Devices to use either ALL production certificates or ALL test certificates. That means must flash the CPX2 SE with a test certificate even by default it has a production cert on it if running on a test network.
  2. Add device in SE platform via RPC first, add link key then…
  3. Flash physical device with the same link key, and set allow joining