Router join

After the firmware upgrade and after every reboot I notice that router use channel 0x0f while coordinator is on channel 0x17.

What command should I issue to the modules(coordinator and router) in order to let coordinator talk with routers?

Router version is Coordinator version is
Scan channel parameters is set to 0x1ffe

In the network there are just one coordinator.
Please note that the same router was working in previous power on.


ANybody can help?

Sometimes router power up and take a different channel than the coordinator.
For exmaple coordina is working on channel 0x0f and router on channel 0x17.

What command should I sent to router and/or coordinator to sincronize each other?

Kind regards

Which firmware did you upgrade to in your router? What are you using for a coordinator and what firmware is loaded on it?

What is the value of your SC (Scan Channels) parameter on your router node? It should be set to 1FFE to enable scanning for all channels so the node is able to find its coordinator.

This behavior can happen if the following steps occurred:

  1. The JV parameter on the router is 0.
  2. The coordinator and router were associated.
  3. The firmware was updated on the router and the router re-associated to the network.
  4. Next, the firmware was updated on the coordinator; which causes the coordinator to possibly choose a new channel upon start up.

This is because the coordinator is only required to start the network. Once a router has been associated on a network it remembers that PAN and channel configuration until it either: 1) it’s firmware is reloaded or 2) it is told to forget them.

In this instance you should be able to issue the NR command with a parameter of 0 (e.g. ATNR0) on the router node in order to instigate it to rescan and rejoin it’s target PAN.

In the future you could avoid having to do this by either setting the JV parameter of the node to 1 (so that the router attempts to find the coordinator every time it starts up) or lock the coordinator’s channel using the SC parameter.

I hope that helps!

Good luck!

Where can I find documentation about router/coordinator association?
I mean how can I associate or disassociate a router and its coordinator?

Jordanh how can I set the NR command on a router that’s already workin in a net?I can send at commands only to my coordinator through the Xctu software, there’s another way to communicate with routers?

Load a xbee with the router API firmware and then on the modem configuration tab of X-CTU look at the top for remote configuration. This firmware can communicate with the AT firmware to set/change the parameters of the radios. Click remote configuration and another window will open. Click open com port then click discover. This is the easiest way to set parameters. You can also send API packets to the xbee to send the NR command.

Thanks for your replies.
I can’t change the routers firmwares, cause they’re packed into closed boxes, so I can access only the coordinator.
So I can’t use the API firmware… is it the only way to set a NR command???

Sorry for the misunderstanding. You will need to get a development board and just one xbee that you migh have laying around. Put the API firmware on that Xbee. I know for sure that you can use X-CTU and that xbee to do remote configuration. You should be able to send the NR command from within the terminal tab but you will have to assemble your own API packet. I have sent NR on the ZB firmware but not the ZNET firmware. If I get a chance on Friday, I will see if I still have the API packet writen down at work and I will send it to you.

really kind! thanks for your reply!