RS485 Wiring and garbled messages

We are trying to communicate via RS485 2-wire to another device and getting a garbled response.

  1. We’ve configured the Transport WR21 to redirect the serial communication through a TCP connection
  2. We connect and send a message through TCP to the device and confirm on the device and through the Digi Analyser log that the message gets there correctly.
  3. The device responds with a repeatable garbled response. As in each message we send always returns the same repeatable garbled response

We can get everything to work by adding a USB RS485 adapter to the wires (wired like you would to include another device in the chain). It only has to be powered and not actually plugged in and the responses are no longer garbled and everything is fixed.

We wondered if this was relating to the grounding described in the digi article below but we’ve verified the items are grounded. We even tried the fail safe suggestion for grounding to power.

I also thought that it might be a flow control setting but we’ve tried all them through trial and error with no affect.

I think I found the answer by adding a 1000 ohm resister from power positive to RS485 positive and 1000 ohm resister from power negative to RS485 negative.

I got the idea to try it from this post:

What firmware were you running?

5236 had this in the release notes:

RS485 support has been updated to allow a 120 Ohm termination resistor to be enabled via configuration. To enable the termination resistor, set bit 3 of SREGs register S16 or via the Serial Interface configuration Web page. (WR21-63)

Perhaps that will help clean up the signal.