RSSI only working in Console Mode, XBee Pro 900HP

I have P0=1 and RP=FF set on all devices, and an LEDs connected to the RSSI pins.

When I have the routing unit connected to the Console Mode in X-CTU, then the RSSI LEDs work properly on all devices after receiving a command (they stay on for 28 seconds). But when I move the routing device to the field then the RSSI LEDs only flash briefly (less than 100ms) whenever a command is received.

Is there anything that would prevent the RSSI pin from functioning correctly on the 900HPs, when P0=1 and RP=FF? Everything else in my setup is working perfectly, and the only problem is that the RSSI LEDs only flash briefly after receiving a command, instead of staying on for a longer time.

The only thing that would affect that is if you did not write (WR) the settings to flash after making the changes to the commands.

Do you mean writing the P0 and the RP commands? I’m pretty sure those are written to the flash, and when I read the settings from any of the Xbees it’s always P0=1 and RP=FF.

One thing I just learned is that if I set the router to AT mode instead of API mode, then the RSSI lights work correctly on all of the devices, staying on for 28 seconds. Is there any reason why when the router is in API mode, it would have a different effect on the RSSI lights of the receiving devices? The commands I’m sending through AT are the same as I was sending through API (I was using Remote AT commands in API mode).

Yes I was referring to the PO and RP commands.

No, I a not aware of any reason why the RSSI function would act differently in API mode vs AT command mode.

Did you have the remote nodes in API mode as well? Was there anything plugged into the UART of these modules?

Thank you so much for responding.

Nothing is plugged into the UART pins.

You gave me the idea to try putting the remote nodes in API mode (they were always in AT mode before), and this causes the RSSI LEDs to work correctly. Is this some kind of a bug? I’m using the latest 10K firmware version (1074), but I know I used to have this problem with the last version too (1071).

So here’s what I got so far: When all modules are in AT mode, the RSSI LED works correctly. When all modules are in API mode, the RSSI LED works correctly. But when the routing module is in API mode and the receiving modules are in AT mode, then the RSSI pin only flashes power for <100ms, and stays off the rest of the time, even when P0=1 and RP=FF.

I’m sorry, I spoke too soon with my previous reply. I just realized that I had forgotten my routing module in AT mode from the last experiment (we already saw that when it was in AT mode, the RSSI LEDs were working correctly on the remote nodes). When I switched it back to API mode, even with the remote nodes in API mode the RSSI LED still doesn’t work.

So currently it seems the remote nodes’ RSSI lights only work correctly when the routing module is in AT mode, regardless of whether the remote nodes are in AT/API mode. I guess then a temporary fix for this situation is to change my program so that every module is in AT mode. I would love to learn though why this strange behavior is happening.

You are saying that your node that is acting as a router needs to be in AT mode for this to work. What happens if you use some of the different TO option bits such as 0x80 or 0x40 for the close range modules (No hop needed).

I have a very simple closer-range setup where hops aren’t needed. Previously the routing module (CE=0) had TO=0x81. I just tested it with TO=0x80, and I had the same result, with the RSSI on the receiving end (CE=2) not working properly.

If you have any other suggestions, I would love to test them out.