SMS problems with Digi LTE-M / NB-IoT

I am trying to send SMS with Digi LTE-M / NB-IoT module. It is working with some modules. But there are problems with newer firmware.

Working module configuration is for example:

XBee LTE-M / NB-IoT firmware 11410 or firmware 11411
Modem firmware L0. [Feb 03 2018 13:00:41]

With newest firmware 11415 and modem firmware L0.,A.02.04 sending SMS always end up to timeout, also receiving SMS does not work.

All firmware versions can register to network and data connection with TCP is working.

Python code, i tried:

>>> import network
>>> cellular = network.Cellular()
>>> cellular.sms_send(“+35840*******”,“test”)
Traceback (most recent call last):
File “”, line 1, in
OSError: [Errno 7110] ETIMEDOUT

What could be the problem?

This is something that you should send an email to over.

Does your SIM card/dataplan include SMS service? Does ATPH report a phone number? If you send an SMS to that number, can you receive it in MicroPython?

Yes and XBee cellular with older firmwares (XBee & Modem) can send and receive SMS in Micropython, but XBee with newest can´t. ATPH reports a phone number in any firmware combination I have tested.

Thanks, I have contacted tech support.

I am Having the same issue with SMS although I get the EIO Error. Was your issue resolved?

Original issue is not solved yet. I got some new steps to solve issue from tech support just a while ago, but I didnt have time to test those steps yet.

Temporarily solution in my case to get my project up and running was to update XBee firmware to 11415 and modem firmware to L0.,A.02.04 and then I manually downgraded modem firmware to L0. while XBee firmware stayed at 11415.

The problem causing EIO error could be something else though.

That’s interesting. Seems they might be thinking its an issue with the cellular component. I have a XB3-C-A2-UT-001 RevK here with 11413 as it was out of the box. I will try SMS on that device. The one that I am having issues with I updated to 11415 and cellular component updated to L0.,A.02.04 before testing SMS functionality.

That does sound like same problem that I had (now its had) because I got it sorted out with tech support. Problem is solved for me by sending AT+USVCDOMAIN=2 command directly to the modem and then AT+CWPROFF after that wait about 20 seconds and reboot. I used USB-direct mode and XBIB-CU-TH dev board to send commands to cellular modem with ublox m-center software. I guess bypass mode could also be used, but seems like it is deprecated.

That’s great news. Did you revert the u-blox firmware back to L0.,A.02.04 before issuing the AT commands?
Also does the issue return after power cycling the device? Some modem devices require a write to memory command after changing settings to make them permanent.

I updated both xbee and modem firmwares to latest and then sent AT commands. AT+CPWROFF (corrected now) seems to save modem settings to nvram before reset. Settings are preserved after reboot - I didnt check by AT command but everything is working after reboot.