SolidWorks Dongle not Seen after Reboot on ESX Server

Hello, we have a virtual server connected to the USB anywhere box. All seems fine and working until the server is restarted. After restart the Solidworks license software reports it cannot see the dongle. Stopping and restarting the HASP service and Solidworks Service fixes this but it’s still a problem long term because we have to login and start the services.

After reboot the dongle appears in device manager with no errors shown.

Most likely, one or both of those services is starting (and looking for the dongle) before the AnywhereUSB is fully connected. As a workaround, I suggest delaying those services, so that they start later, especially after the AnywhereUSB service (awusbsys).

If you do a web search for how to delay a service you should get lots of hits, for example:;en-us;193888

The bottom section is most relevant to you (making your USB key-related service run after another one that’s known to start late), particularly “Note If you have a service that needs to start late in the boot cycle but you do not have a specific service dependency, as explained above, then choose one of the services which startup last as the data value for the value “Depends on Service”. Services commonly selected are Spooler and Messenger.”

Thanks for the reply. Interestingly I don’t have that service showing at all in my service list: AnywhereUSB service (awusbsys).

I think the AnywhereUSB service is an older kind of service called a “NT service”, so that’s why it’s not listed with the others in the services console.

You can find awusbsys in the registry, in “HKLM/System/CurrentControlSet/Services/”.

Note that you may not necessarily have to make your service(s) be dependent on the AnywhereUSB itself. If you can delay them after another service that’s known to start late (i.e. Spooler), that may achieve the same end result.

I’ve found the service, I’ll try making it dependant on that service and see what result I get, will have to test it out of hours and let you know the result.

A big thank-you for your help

Hello, I discovered that it is only the solidworks license manager service that needs restarting. I made this service dependant on the spooler service but still the same error. I also tried making it dependent on the USB service and again no joy.

Do some research on the web to find other services that are known to start late in the boot cycle and then making the solidworks license manager service dependent on them instead. Try the Messenger service for example, at minimum, if you haven’t already.

Let me know if that helps. If not, let me know what other dependent services you tried and we’ll go from there.

Hello, tried researching services but no where can you find a list of what order they run in. Don’t think Microsoft really want people fiddling with them incase you cause your pc to fail to boot with services stook in a loop.

I have overcome my problem though by running a startup script which runs on startup, waits for 2 minutes then stops and restarts the Solidworks service. This seems to allowing the Solidworks service to pick up the license dongle.

Thanks for your help.