USB Anywhere and Solidworks dongle

We’re experiencing difficlties when using USBAnywhere and a solidworks dongle. (Aladdin product).

We’re running a Windows Server 2003 VM on an ESX server 3.0.1.
The VM properly connects to the USBAnywhere and I can see the dongle device in both the device manager, as well as in the USB Viewer Utility.
Nevertheless, the licence manager is still telling us that no dongle could have been found.

We even installed the Aladdin HASP4 software, no luck with that either.

Anyone experiencing the same problem and has a solution for us? Any help is greatly apprechiated!

When you look at the dongle in Device Manager and the AnywhereUSB Viewer Utility are there any yellow icons (“warning signs”) by the solidworks dongle or (if not) does it appear to be installed OK?

Everything looks perfect! No yellow signs in either the Device Manager or the AnywhereUSB Viewer Utility.

The Dongle gets recognized perfectly in device manager and states that it is a Aladdin dongle.

I just let my colleague check the dongle against the AnywhereUSB check utility and this is the output:

0 USB devices found
No incompatible devices found
No compatible devices found

Now I suspect that the dongle is isochronous and therefore not supported by AnywhereUSB, altough it shows up perfect in both the viewer utility and the windows device manager?

Any help or advice is apprechiated!

Message was edited by: mhuber

The AnywhereUSB check utility only looks at local (directly-attached) USB devices, not devices attached to the AnywhereUSB, in case you were running it that way. Note where it said “0 USB devices found”. FYI, if an isochronous device was detected it would be “found” and listed as incompatible. Most likely that dongle is not Isochronous, as those kinds of devices are higher speed devices.

My best guess is that the issue has to do with the software applications that are looking for that dongle. Do you have a contact with either of those vendors so you could ask them if their software is only designed to look for related dongles on local USB ports, and if it “should” work with a network-attached USB hub such as our AnywhereUSB? I’d be glad to contact them myself if you could provide me with contact info.

Thanks Jeremy for your proactivity.

Indeed, the dongle was directly attached to a local USB port when we ran the check utility.
I am trying now to get in contact with our vendors in order to get more information from that end, altough expectations are low. I could both try Solidworks (as software vendor) and Aladdin (as dongle manufacturer). As soon as I have more information from either one of them I update this thread.

Thanks again for all your help.

I’ve done some research in the solidowrks forum and it appears that one guy experienced the same problem as I have, but with the USB donge locally attached.
Our setup: Windows Server 2003 Standard edition.

When he tried to do the installation over RDP, he ended up with the same error message as I had. As soon as he tried directly thru the console, the recognition of the USB dongle worked.

I will try this as well, but since we already use the dongle productively I have to wait until off-business hours to do some more testings (most likely at the weekend).

Will keep this thread updated as soon as I have more information.

Message was edited by: mhuber

Sorry that I didn’t replied my answer earlier, but it seemed that the forum was down for quite a bit. :frowning:

Finally, I could get the solidworks dongle get to work with USBAnywhere. The solution to the problem was that I had to go thru the console (Virtual Infrastructure Client) to be able to let the FlexLM software see the USB dongle.
So, the USBAnywhere box is also compatible with the solidworks dongle, altough, as I mentioned earlier, it couldn’t detect it with the check utility.