USB dongle not working correctly on win2003


We actually plan to migrate our license server to a VMware server. The current server (win 2003) is using usb dongles. In order to verify that a VM can afford the same job, i installed a VM with Windows server 2003 and connect it to my USBanywhere box. I plugged my dongle (Orcaflex) and installed the drivers. Everything is detected and installed but the softwares can’t use the dongle (Alladin HASP). I tried the same on a XP VM and it works. Here are the steps i did :

-Copy usbd.sys from CD to “c:\windows\system32\drivers”
-Install USBAnywhere drivers & setup connection to my USBAnywhere box
-Plug my key in the box and then install drivers.

So my questions are
-Is there a limitation using USBAywhere with win2k3 ?
-Did i do something wrong ?

I also tried to deactivate DEP with boot.ini and start HID service without results.

Any help is welcome.


Are you connected to the AnywhereUSB? Are the AnywhereUSB components installed successfully? These are the things to check first. To determine the answers, upload the following screen captures:

  1. AnywhereUSB Configuration Utility
  2. Device Manager (maximized) with the USB section expanded.

-I am connected to the AnywhereUSB.
-The AnywhereUSB components installated correctly (exept messages about “non digitally signed drivers”).


Looking at your Device Manager screen capture, both the AnywhereUSB and the Aladdin Key appear to be properly installed.

Am I correctly understanding that, using this exact same Aladdin Key and AnywhereUSB on a Windows XP virtual machine “works”? “Works” meaning that the software associated with that Aladdin Key can successfully see the Aladdin Key?


Installation of AnywhereUSB and Aladdin USBKey is ok on both XP and 2003 server.

On XP VM : The usb Aladdin Key is seen by the software.
On 2003 server VM : The usb Aladdin Key is not seen by the software.

You mentioned that you were using a physical Server 2003 PC at one point in time. In that scenario, did the software associated with the Aladdin Key see the key?

Yes. The actual license server is a Win 2003 server and all keys are seen (but it’s not a VM). This problem only occurs when using a Win 2003 server VM.

That tells me that the software associated with the Aladdin Key seems to be compatible with Server 2003. Perhaps the issue is due to the combination of Server 2003 and VM. As far as what I can do to help, there’s nothing to configure related to the AnywhereUSB that might help this. so I’m just about out of suggestions. As you can see, the dongle appears to be installed properly. You could try other AnywhereUSB driver versions or driver versions for the Aladdin Dongle but I don’t think that would make a difference since. I recommend contacting the support group of that software to get their thoughts.

I already tried many driver versions combination for both usbanywhere and Aladdin key without any result. I’ll try to contact Aladdin.

Thanks for time spent.