awvusbd.sys causing BSOD on VM 2003 server


I have a 2003 VM server with USBAnywhere5 installed. I started off with the v2533 software. Then started getting BSOD every couple of days at what appear to be random times i.e. middle of the night/morning etc. I then downloaded the lastest software v2670. Same thing happened. I then removed the software installed v1.80 from 2006. Still BSOD. This server also has HASP Sentinel 5.86.

I’d greatly appreciate any help!!!


Try the new v3.10 AnywhereUSB driver and let me know if that helps or not.



Thanks I’ll give it a go. It can take a couple of days for it to crash but I’ll let you know how it goes.

BSOD again.

Please open a support case with us and reference your forum topic by entering this URL in the case notes:,8020

I will take your case and reply to you there to continue troubleshooting.

If you don’t already have an account on our support site, please create one.

I seem to have the very same problem. I have a windows server running in VM Ware ESX and I have AnywhereUSB for the USB security dongle. The system is constantly having BSOD and while it is working most of the times it can not see the dongle.


We are aware of a bug with some of the HASP drivers, that causes a BSOD when used with the AnywhereUSB. It’s my best guess that you are running into that bug.

We made the vendor (Aladdin) aware of this bug. Unfortunately there is no workaround that we are aware of. We suggest contacting Aladdin and asking them to fix that bug.

Hi Jeremy,
funny thing is that this bug does not affect anything if the dongle is connected to the machine it self. I have no problem whatsoever if I run an exact replica of the system and connect the hasp dongle directly to the computer.

Right, that’s actually expected. The bug is only introduced when their dongle/driver is used with our AnywhereUSB.

If anyone is still affected by this issue (using SafeNet dongles with SafeNet drivers, i.e. HASP, in conjunction with the Digi AWUSB), please contact Digi tech support. SafeNet provided a new dongle driver that should have the bug fix.

I tried calling Digi but he told me they do not supply dongle drivers, he was supposed to send me info by email for safenet but never got anything, I will try to call safenet but this is exactly what’s occuring on my systems

tried contacting Digi but they say they dont supply drivers?