SPI does not work on version 4.0

Hello

We have a device with SPI 4, and SPI worked on Yocto 2.4, 3.2 but doesn’t work with 4.0.
We repeat examples based on link, but still no SPI device https://www.digi.com/resources/documentation/digidocs/embedded/dey/3.2/cc6ul/bsp_r_spi_6ul

Digi Embedded Yocto 4.0-r1

U-Boot dub-2020.04-r5.6 (Nov 29 2022 - 11:07:14 +0000)

CPU:   i.MX6UL rev1.2 528 MHz (running at 396 MHz)
CPU:   Industrial temperature grade (-40C to 105C) at 45C
Reset cause: POR
I2C:   ready
DRAM:  256 MiB
MCA:   HW_VER=1  FW_VER=1.20
PMIC:  PFUZE3000 DEV_ID=0x30 REV_ID=0x11
NAND:  256 MiB
MMC:   FSL_SDHC: 0
In:    serial
Out:   serial
Err:   serial
Model: Digi International ConnectCore 6UL SBC.
ConnectCore 6UL SOM variant 0x06: Industrial Ultralite 528MHz, 256MB NAND, 256MB DDR3, -40/+85C, Wireless, Bluetooth
  Board version undefined, ID undefined
Boot device:  NAND

On boot logs no mention of SPI, but if we make mistake on the device tree we meet an error
Modporbe spi empty output

root@ccimx6ulsbc:~# modprobe spidev
root@ccimx6ulsbc:~#

Even an empty project with dey-examples doesn’t work.

May you check please work with spi 4?

Device tree

&ecspi4 {
	num-cs = <1>;
	pinctrl-names = "default";
	status = "okay";

	/*
	 * Configure the GPIO that you selected as 'slave select'.
	 */
	cs-gpios = <&gpio3 26 GPIO_ACTIVE_LOW>;

	/*
	 * ECSPI4 (as master)
	 */
	pinctrl-0 = <&pinctrl_ecspi4>;

	/*
	 * Reference block.
	 *
	 * Add your slave devices here. Next is an example of spidev.
	 * Expect a harmless kernel warning if you enable spidev as slave.
	 */
	spidev@0 {
		reg = <0>;
		compatible = "spidev";
		spi-max-frequency = <1000000>;
	};

};
pinctrl_ecspi4: ecspi4grp1 {
			fsl,pins = <
				MX6UL_PAD_ENET2_TX_EN__ECSPI4_MOSI		0x10b0
				MX6UL_PAD_ENET2_TX_CLK__ECSPI4_MISO		0x10b0
				MX6UL_PAD_ENET2_TX_DATA1__ECSPI4_SCLK		0x10b0
			>;
		};