Start Program Execution with "Dynamic C Target Communications protocol"

Hi all,

After downloading a program to a RCM3400 with Dynamic-C it starts execution and breakpoints to first line. Then you press F9 and it runs.

But this is not the same when using Rabbit Field Utility (RFU). Program is downloaded to uProcessor but do not start automatically (I assume it is also in breakpoint mode). So I have to make hard-reset to run it, but I do not want to.

Does anybody know which code is needed to transfer by serial port to start execution of the code after RFU’s download? download&run…

I tried to send triplets 0x80 0x24 0x80 to force the start but doesn’t work. Maybe because the Dynamic C Target Communications protocol is now active.

How can I start execution after RFU’s download without reseting?

Is there any information about Dynamic C Target Communications protocol, so I can try it?.

Good afternoon, Have you tried using the latest version of Dynamic C? I would test this using a Flashled sample

I’m using DC9.21.

It’s not a matter of SW I guess, no matter which sample I use. After downloading the code, you must press reset to force the execution.

I do not have physical access to the board, that’s why I wanted to do a reboot by SW.