SX 868 XCTU Error Reading AT Parameters > Connection time out

I have a test network with 2 SX868 Digimesh device in API mode.
A third device is connected to a laptop running XCTU to monitor the network.

The test network devices are configured exactly the same except for the NI node identifier parameter.

On applying power, both test network devices act the same. After a few minutes, one device (always the same one) doesn’t respond to a remote read command from XCTU. It does successfully initialize but it can’t read the parameters. I get the error message: Error Reading AT Parameters > Connection time out. The same error message is returned when read locally through the serial port. The SX868 is connected to a Raspberry Pi.

It is like the device is locking up or going into sleep mode but SM is set to “normal”.

I considered the possibility of a hardware fault, so I swapped in a replacement device with the same configuration. I got exactly the same result. It is highly unlikely that two devices would have the same hardware fault.

I tested the device swapped out with XCTU. It worked perfectly. The only change I made to the config was to disable RTS/CTS because I used a flying lead to connect TD and RD to the development board. This should not make any difference.

Any suggestions on troubleshooting this problem?

Testing indicates that flow control is the problem on the Raspberry Pi. It appears that when the flow control is not working, the Digi device buffers fill and then stop accepting new data. This is reported as a connection time out. It then looks like the Digi has frozen whereas it is actually waiting for buffers to be read and cleared to make space for new incoming data from the wireless connection or the serial port.

Even for me same error.