TCP Socket Profile/TCP Client issue with Digi One Sp

I’m having an issue with using the TCP Sockets profile on a Digi One SP. I’m using two digi’s both setup as TCP clients that connect back to a TCP server.

Additional Information:

TCP Server(Software): Port: 9999

Digi #1(working):
Digi #2(not working):

TCP Client config for both Digis:

Automatically Establish TCP connection: Turned on
Connect: Always
Connect To:
Service: Raw
TCP Port Number: 9999
Flush Start Character: Auto
Send Keepalive Packets: off
Auto Drain on Close: off

One digi works perfectly (With Firmware 87000774_V2) the other one connects but never connects correctly (Firmware 82000774_W) .

Both setup exactly the same (Also i’ve tried these secluded one at a time to make sure one wouldn’t mess with the other.)

When I have them connected the working one under connections shows an active network connect:
(TTY:1, Username:root, Connected From:Port 1, Connected To:None, Sessions:1)

Now if we look at the digi not workings Active network connection I get this:
(TTY:1, Username:root, Connected From:Port 1, Connected To:Command Line, Sessions:0)

The session and Connected To is the only difference other than the firmware that I can find between the two. I never see a connection on the TCP server from the non working digi even though it shows a connection in that screen for that digi. (Also, I’ve tried replacing the non working digi with a new one but still no luck.)

Any Thoughts? Thanks for any help…

Please post the results of the following commands run from the root prompt of the working and non-working units. You will need to use telnet or SSH to connect and then login as root.

#> who
#> set port
#> set auth
#> display port

Hopefully, this will give some clues.