Trouble associating HA profile devices with XBee/ XBee PRO Series 2

I’m trying to associate home automation end devices based on the TI Z-Stack to a XBee Series 2 (and/or XBee PRO Series 2) running the ZigBee Coordinator (binary API mode firmware, version 2170).

The strange thing is that I’m (almost!) sure I succeeded a few weeks ago, but I cannot replicate my success any more.

What I have been able to do easily is have a XBee running Router firmware associate with a Z-Stack based coordinator and be able to talk to the end devices that way.

But XBee as a coordinator … no luck today. Firmware is 2170 and my settings are:

SC=0x02 (I know these devices work fine on channel 12 decimal)
EE=0 (no encyrption enabled on the end device firmware)

Looking at what’s happening in a packet sniffer:
I push the associate button on the end device. Association seems to proceed and complete normally. Association LED blinks on end device indicating successful assocation. Then after a pause of 10 seconds the XBee continuously fires “Leave” commands at the device… and these “Leave” commands continue at a few packets a second indefinitely. Any attempt to communicate with the device fails. It seems not to have associated (or was kicked off soon after association).

I can post PCAP packet logs if that’s of any help. I’m sure I’m missing something small…



yes Joe, can you send the PCAP and if you also use the TI sniffer, can you send the PSD file as well so we all can look into it?

My goal is a home automation setup with equipment from a few vendors. The XBee module will be the coordinator and computer interface to the network.

I’m attempting to associate a device called the ‘ZRC’ from a company called ‘Cleode’ to the XBee.

I’ve attached PCAP files of a successful association with their coordinator device (called a ‘UBee’ and again TI based) and a PCAP of my failed ZRC -> XBee association attempt. The PCAP was captured with Wireshark + Microchip ZENA sniffer. Unfortunately I don’t have the TI sniffer.

The annoying thing is that I encountered this same problem a few months ago and somehow I managed to get it to work, but looking at my notes … i failed to record the critical change required.

BTW: I have no problem having the XBee communicate with these devices if the XBee is a router and associates with the UBee coordinator – they all talk together nicely that way.

Hi Joe,

did you manage to make it work finally?? I’m trying to do the same thing with HA thermostats. For now I have managed to join my thermostat to a ConnectPortX2 for a couple of seconds…

I tried looking at what the coordinator prints through endpoint 0 (API feedback with python), and when I try to join my device, I get 5 Zigbee Transmit Status success frames in a row in about 15-20 seconds (all containing different network addresses). So my guess is that I’m stuck where you were, my thermostat joins, gets an address and then gets a leave command (I can clearly see that for an instant, the join succeeds). In the thermostat specs, it says that it will try to rejoin 4 times after joining once, so that would explain the 5 API frames… But now, I’m stuck…

So, what’s next??

BTW : for my part, I enabled encryption and I set the link to the default HA link key value. I’ll try disabling it this afternoon…



No joy, but I didn’t try very hard since. The network coordinator I use has TI hardware/firmware and I’m looking at using that as the interface to the network instead. The annoying thing is that I’m pretty sure I did get it to work once… but I have no idea how.


I’m so sorry to reply this 3 months later… >.<

I just looked at the pcap files… From the looks of it, I suspect that the Sniffer isn’t doing a good job at sniffing the entire packet. (Note: I could be wrong!!)

I’m saying this because the sniffer did not record the response cluster that was sent. Look at Packet 20 of fail.pcap and Packet 17 of pcap.success. Or it might have been you did not enable the feature… And from the looks of it, it’s missing a whole other bunch of information that was supposed to be sniff!

The point of having the cluster response and request sniffed is to look at whether does the node support that Zigbee service…

From my assumption, my guess is that the XBee node does not support the HA Profile request that your device sent, so everytime there’s a data request from the TI node, it was an invalid request… thus kicking it out of the network??

Can you turn on the feature, or it would be better if you can use the TI sniffer for CC 2531 USB Dongle if you have it?

Edit 1:
Looking at the recent response you gave from here you seemed to have the dongle with you… Have you tried to sniff this problem you were facing yet?

Edit 2:
Read this [Link ]. I assumed the issue is still present. To overcome it, you need to allow your Host Intelligence to process the HA Profile request.

Hi Joe,

I am interresting to buy a HA endpoint more particularyCleode ZRC.

Have you successed to connect your Cleode ZRC to a coordinator Xbee ?

thanks in advance