unable to connect to digi Connet ME device using RAVEN and GDBtk

I’m currently using the GNU tool suite with a RAVEN Debugger to connect to a Digi Connect ME device. I am unable to connect to the device at all.

After compiling the naftpapp program I attempt to connect to the device and Download the program but receive the error “Unable to initialize : Cable Disconnected” from OCDLibRemote. I have downloaded and Run the Raven_test program from macraigor.com and the test passes so I am pretty sure the cable is connected and the Raven device is communicating.

Any help would be sincerely appreciated.


Is the Raven connected correctly to the JTAG connector on the ME dev. board?

What I/O address is your parallel being reported as using (378, 278, etc.), in the device manager? It has been my experience that OcdLibRemote.exe accesses the parallel port directly via it’s I/O address. This means that although Windows may say that you port is LPT1, if it is using an address of 278 (instead of 378) OcdLibRemote.exe will treat the port as LPT2.

I am not certain as to whether rav_tstr.exe operates in the same fashion or if it uses the Win32 API.

If this does not help, please call Digi Support at (952) 912-3258.


changed the port address to 378 but get the same error. tried connecting via gdb command line with
“source c:
and get the foolowing error
Error: c:
etos60_gnu\gdbtkconnectme.raven:272: Error in sourced command file:
“monitor” command not supported by this target.

could this be the real problem and if so any ideas on how to fix this?

thanks for the help so far


Just my two cents worth -

Make sure that you restart gdb every time. The errors that you are getting are the ones I get when I try to reload the Raven without exiting and restarting gdb.

Also make sure you restart OcdLibRemote every time.