Unable to update firmware

Hi !

I’m using Xbee ZB Developement Kit, and I’m trying to build a network between two Xbees (S2B) and an Xstick (wich will act as Coordinator).

I’ve tried to implement ZHA Profile (Light and Switch) using the Code Warrior environnement and the part of code given by Digi, so I think I “flashed” my module with some new firmware (API mode of course). Am I write here ? I mean, does the code given by Digi modify the firmware ?

Well, whatever, my problem is that I can’t build my network, because when I use “Remote Configuration” and “Discover” from my Coordinator, it doesn’t “see” the both Xbee, juste one router is detected.
(It used to work a month ago but I can’t recall what I’ve done that made that change :blue: !)

I thought the problem came from the pan ID, but I load exactly the same Digi CodeWarrior project in both modules (with pan ID to 00)… So then I thought the problem come from the firmware version.
Actually in serial console, I can see the firmware version on reset (thks to my project), so the “good” module has a 2370 Firmware and the “bad” one, has a 23A0 firmware.
That’s why I tried to update the firmware on the bricked module, but I couldn’t anymore.

I already try to update by starting with my xbee unplugged from my board, and plug it when the “Action Required” message… It didn’t work…

Moreover, I’ve never been able to communicate white AT command since I’ve pushed my CodeWarrior project into the module.

Does anyone have any idea of what to do ?
Please help :slight_smile:

Thanks ! :slight_smile:

PS : I’m quite sure about my undestanding regarding “Bootloader” and “Firmware” so I’m sorry if my explanation are a bit confused

If you are not able to access programmable XBee modules, reflashing the firmware may help.
Put the module into bypass mode, http://www.digi.com/support/kbase/kbaseresultdetl?id=3291
Write the firmware, if Action required window pops up, click Cancel and try with different baud rate while writing the firmware.

Thanks, I didn’t see your answer earlier.
By any chance, do you no why my bootloader menu just come “in loop” and when I type “B” to enter Bypass Mode, nothing happen ?

I even though try to go to Modem Configuration Tab and Write my Configuration after typing B… but X-CTU software just crashed…

Any idea why ?