Unique XBee Pro S2B Setup

Hello all,

This is my first post of what I would probably say is many and I was hoping someone may be able to help me out.

My setup is fairly unique because I am using a custom designed PCB with an XBee Pro S2B hard-soldered on it set up as a ZigBee Router API. I am using another XBee Pro S2B on a Digi XBIB-U Dev Board set up as a ZigBee Coordinator API to communicate with the PCB XBee.

I have a couple of issues and was wondering if you all might be able to assist with some solutions. On the PCB I am using, there is a microcontroller that is using a serial bus to communicate with a product I work with. Because of this microcontroller, I am unable to communicate directly to the XBee on the board using my PCB’s serial connection. Since I am unable to communicate with the XBee directly, I can’t find out what firmware version the XBee on the PCB is running.

Based on the above, is there a way to grab the firmware version of the PCB’s XBee using the Coordinator?

I am able to see the PCB XBee using the Coordinator on the Remote Configuration screen in X-CTU but can only see the address of the PCB XBee and the version of the firmware is not listed.

Is there a way to send a command to the PCB Xbee through terminal to have it respond with its XBee firmware version?

Also, is it possible to update the firmware wirelessly, if necessary, using this setup? I tried using the Coordinator to do the update but the microcontroller on the PCB is blocking serial access to the PCB XBee.

Thank you in advance for any help and please let me know if you have any further questions.

-William Gardiner-

pg. 108 of the xbee guide shows how to do a ‘remote AT command’. You can use the ‘VR’ AT command to get the firmware version.



Thank you for your response. Either I am doing something wrong (sending the wrong packet command) or my microcontroller is not letting the XBee send out the response to the command because nothing gets sent back when I send the below command.

The command that I am sending is: 7E001017010013A20040927271A75A02565201F5.

This was created using the Pg. 108 reference. The address of the PCB XBee is 0013A20040927271 with a Short Address listing in X-CTU of A75A. Maybe I am assembling the command incorrectly.

Any input would be greatly appreciated. I am thinking that it is going to be impossible to check anything relating to the PCB XBee until I clear the firmware from my microcontroller entirely and take it out of the equation (which I would prefer not to do).

-William Gardiner-

HI William,

Contact Digi Tech support over this one. I’m a little shakey on API packets. Ask to speak to the Lindon office. They have people that are very good at this sort of thing.

good luck sir,



Hello WGardiner ,

Try this to build the frame: ftp://ftp1.digi.com/support/utilities/digi_apiframes.htm

Also, use FFFE for the 16-bit address (it may change every time you power the XBee).

Finally, in the Remote Configuration tab of the X-CTU, select the node and click on Read button to see the XBee configuration remotely. However, I never tried updating the whole firmware this way (only changing parameters) let us know if it worked.

Thank you all for the replies.

RE: spastor; I tried using a frame constructed using the utility you linked and there still was no response from the PCB XBee module. I am bookmarking that reference, however, because it is a really nice tool that I will probably use in the future. Thank you for that.

The reason nothing is working is because of the microcontroller I am using on the PCB. The microcontroller is being used to send data from a modbus through the PCB XBee to a Proprietary ConnectPort Gateway. While the microcontroller is programmed, the XBee has no control over its actions, resulting in the issue that I am having. This also happens when I try to update the firmware via the Remote Configuration tab. A Modem is found, but the version and type is unknown due to the microcontroller.

The only way I have been able to find the version number of the PCB XBee is to completely erase the microcontrollers firmware, basically bypassing it entirely.

Now that I have found a way to get this, I was wondering if anyone knew of a way to reprogram a microcontroller remotely through the PCB XBee? I know this sounds crazy, but I want to know if something like this is even remotely possible or if I am just grasping at straws, so to speak. I am using the Microchip PIC24FJ256GA106 IC.

Thank you all for your help and advice.

-William Gardiner-