Upgraded to Windows 10 now 8s won't register at startup

My 8s was working fine under Windows 7 Pro. Then upgraded to Windows 10 and now it won’t register at startup. If I pull the USB plug and then reinstall it, the computer then registers it and it works fine. I don’t see any Windows 10 drivers and I have the latest drivers according to the downloads.


Windows 10 isn’t officially supported yet with Edgeports, so there could be issues. I’m sure a new driver will be released in the near future, with Windows 10 support. My best recommendation until then is to unplug the Edgeport, uninstall it (through the EP Config Util), reboot the computer, then download and install the most current driver (for Win 7), to see if that helps.

Any updates on this? It does seem to (mostly) work fine under Windows 10 Pro 64 bit, but looking to see if new drivers/firmware/statement of support will be released soon.


I did as you suggested but it’s still doing the same thing. From a cold start, you have to pull the USB cable out and reseat it to power it up. However any reboots it continues to work.

No change on my end with W10 Pro 32 bit. Still have to pull the USB plug out and reseat every morning when starting the computer.

After you start the computer (but before unplugging/re-plugging the USB cable) what is the color/activity of the System Status LED? Is the EP listed in Device Manager (if so, does it look OK or does it have any yellow ! warning icons?).

After starting the computer and when windows 10 stops at the login screen, there are no lights on the 8s at all. I will confirm tomorrow morning, but I’m 99% sure it does not register in the device manager, because as soon as I pull and reinsert the USB plug, the computer chimes 4 times and the led starts out red then green then amber for a short time then back to green until the program that uses it boots up. Once the program is up it flashes amber as usual.

Also, in the device manager the 8/s is located under IonMultiPortSerial. There are 4 entries under this heading and each of the four has a tower icon with a question mark followed by Edgeport 8/s.

If I right click on one and select properties, Driver Date is 4/5/2013 and Driver Version is

I have tried a EdgePort/8S on a Windows 10 computer and have not seen the issue you are describing. I have been rebooting to ensure I can recreate the issue you are seeing. I will attempt to recreate the issue on a different Windows 10 computer. Have you tried a different Windows 10 computer to recreate the issue?

When you say rebooting how are you doing this. The problem is from a cold start. When I start up in the morning after the computer has been powered off all night is when the problem occurs. After the 8s has been initialized, rebooting the computer is not a problem, the 8s continues to work after a reboot. I also took a look this morning before I pulled the USB plug and the 8s is not in the device manager. As soon as I pull the USB plug and reinsert, it registers in device manager. I have never had this issue since the purchase of the 8s and with Windows 7 Pro it always registered. All started with Windows 10. No I have not tried another computer, I only have my laptop with Windows 10 but will give that a try at some point.