Why do I get status error when I try to set XBee D4 to Dout Low?

Hi, I am still trying to work out the best way to program 100 XBee S1’s for low power consumption.

I have a sparkfun USB explorer. This is the new one with the handshaking connections. Last week I worked out that I could connect to the XBee with it plugged into the explorer using Discover and ticking the Hardware handshaking. I managed to set D4 to Do Low at that time.

I am trying to do it again now and I am getting a “Error writing the following AT parameters: -D4 Status Error”

Can anyone tell me what else I have to so I don’t get a status error?


Where are you seeing this status error? What version of firmware is install on the radio?

I see the error in a pop up window on the XCTU software after clicking the pen to write to the device.

Firmware version is 10ed

What happens if you set the value via the Terminal tab and AT command mode?

I have just tried to repeat getting the Status Error and cannot recreate the situation. When it resurfaces I’ll try using the AT commands as you requested.

I was getting the error again and tried using the terminal and AT commands and when I typed ATD44 the reply was ERROR.

Are you able to reproduce this issue using an XBIB-U-DEV or XBIB-R-DEV development board? If so, how?

Sorry, I’ve never heard of those development boards

The XBIB-U-DEV and XBIB-R-DEV are the development boards that come with the Xbee modules when you purchase a Development kit from Digi. They are the original development board for the XBee product line.