Windows 7 detects XBee coordinator as a MOUSE

Anybody know how to stop win7 from detecting an xbee serial adapter as a Mouse? It think it’s a “microsoft usb ball point mouse” and won’t let x-ctu run any more. Happened after some stupid win7 update.

I did a little research on this and found the problem happens when you attach an FTDI serial port that has active data on it at the time it is plugged in. I never noticed this until I activated my Xbee analog I/O adapter, which is configured to report once a second.

You can find some information by searching the internet for “microsoft serial ballpoint ftdi.” This Article is a little bit old now but it’s the exact problem. Folks with USB GPS receivers using FTDI have complained the most.

The fix of deactivating the BallPoint driver after the xbee adapter is plugged in only sort of works. You can use Terminal mode of X-CTU but if I try to go to remote node configuration X-CTU just crashes out. The only way i can get it to work reliably is to deactivate enough xbee devices that the network is more or less idle when I plug it in.

I tried the registry hack where you set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SerMouse to startup mode 4 (instead of 3) - whatever that means - and it didn’t seem to fix the problem.

This is extremely painful, and is part of the reason I despise Windows so much. I wish we had a linux version of X-CTU.

If anybody has a solution to this problem please let me know. Otherwise, I figured at least I should document it on the forum in case somebody else runs across it.


Thank you very much for sharing the solution. I’ve never experimented this error, I guess it’s a matter of time…

Now you mention a Linux version, you may try with Moltosenso, it’s multiplatform but I never tried it on Linux, only Windows version and the fonts were quite ugly…