WR31 Not Getting IP Address


I’m having difficulty in my initial bringup of the WR31. We have the WR31-M52A-DE1-TB in house and are trying to get it to connect to the Rogers LTE network in Canada. Primarily I’ve been using the web interface with little success. Here’s what I’ve tried so far, let me know if there’s some step I’m missing.

  1. Tried the quick start wizard shown when device is first booted
  2. Tried following the guide here: http://ftp1.digi.com/support/documentation/QN_002_Configure%20the%20Wireless%20WAN%20(PPP)%20interface.pdf
    With guide, I tried out rogers-core-appl1.apn APN as well as the Rogers LTE ltemobile.apn
  3. Tried removing default dialout number, and set PPP1 to default settings

For reference, here’s the output of Management -> Network Status -> Mobile:

Mobile Connection

Registration Status: Registered, home network
Signal Strength: Excellent (-90 dBm)
Signal Quality: Excellent (-8.5 dB)

Mobile Statistics

IP Address: Not Available
Primary DNS Address: Not Available
Secondary DNS Address: Not Available
Data Received: Not Available
Data Sent: Not Available

Mobile Information
Results of Last Module Status Poll at 1 Jan 2000 22:16:28
Outcome: Got modem status OK
SIM status: READY
Firmware Carrier ID: AT&T/Generic
Signal strength: -65 dBm
Radio technology: WCDMA
Signal quality (UMTS): RSSI -57 dBm, Ec/Io -8.0 dBm
Channel: 4383
Cell ID: 043802A
Network: ROGERS, 302720
Service Domain: CS+PS
Manufacturer: Telit
Model: LE910-NA V2
Firmware: 20.00.505
IMEI: 358148061667932
IMSI: 302720610257220
ICCID: 89302720523073171666
Phone number: Not available
Preferred system: Automatic
GPRS Attachment Status: Attached
GPRS Registration: Registered, home network
Network Technology: UMTS/HSDPA
Connection Status: Normal, unspecified
Temperature: 27C

Make sure your SIM is provisioned and ask your carrier for correct APN