XBEE 802.15.4 retro-compatible hardware?

I have some new purchased modules that as coordinator don’t see my old modules as end device.
I use both legacy and new X-CTU,

The new modules are:

  • PN XB24-AWI-001 rev G
  • Firmware version: 10EF
  • Hardware version: 1747

The old modules are:

  • PN XB24-API-001 rev C
  • Firmware version: 10EC
  • Hardware version: 1743

I upgrated an old module coordinator with 10EF version and continue to see my old end device. Therefore I think that there is some problem in the hardware revision.

Try restoring all to defaults and then run a simple range test. They should communicate regardless of how old the module is.

Nothing. I tested the new module and two old modules with the default firmware settings respectively, but only the old modules discovered among them without the new module. The new module doesn’t discovered the oder two.

That sounds like a faulty module. I would suggest talking to your place of purchase about an RMA for it.

Ok, I found a solution but i don’t know what is the problem.

I’m using these modules with a PARALLAX 32400 rev C to connect XBEEs with my computer.
I retried the same test with the computer of my colleague and the new module is able to communicate with my old XBEE end node.
I tried this test also with another computer and the communication doesn’t work as on my computer.

I reached a stable and functional test only if I plug the PARALLAX to an USB Hub. With it the new module is able to communicate both from my PC and from the other that doesn’t worked.

As introduced before, I don’t know why!

If some of you found the same problem, please comment this.