XBee Cellular connection issue (CI reading 0x024)


I’m trying to set 2 XBee Cellular LTE CAT 1 modules with static IP address to talk to each other.
I set following parameters
DL(Destination Address) to each other’s IP address.
DE(Destination Port) matches to the other XBee cellular’s C0
C0(Listening Source Port) matches to the other XBee cellular’s DE

I choose AP(API Enable) as Transparant Mode[0]
IP(IP Protocol) as TCP[1]

When I try to send messages in the console mode, there is no message received.
I check the CI(Protocol/Connection Indication) is 0x24

base on the documentation, 0x24 is No server - timed out on connection. What is that mean? Both of my modules are working properly before I sending any message. The RED LED indicator on dev kit board is blinking every second.

I keep both modules’ TM and TS at the default setting, 5 minutes.

Here is the copy from documentation about the CI code.
The following table provides the parameter’s meaning when IP = 1 or 4 for TCP connections.
Parameter Description
0x00 The socket is open.
0x01 Tried to send but could not.
0x02 Invalid parameters (bad IP/host).
0x03 TCP not supported on this cellular component.
0x10 Not registered to the cell network.
0x11 Cellular component not identified yet.
0x12 DNS query lookup failure.
0x20 Bad handle.
0x21 User closed.
0x22 No network registration.
0x23 No internet connection.
0x24 No server - timed out on connection.
0x25 Unknown server - DNS lookup failed.
0x26 Connection refused.
0x27 Connection lost.
0x28 Unknown.
0xFF No known status.

Are you working with a private IP address from the carrier or an open public IP address? The ones that Digi provides on the SIM is private.

Thanks for your response. we are using a private IP static address from Verizon.

To do what you want, they both have to be public IP addresses. Not private.

I’m confused because I have done this before and currently I have a pair of XBee Cat 1 modules are working under this mode. BTW, the working pair I have is using a special APN name which Verizon provides to us. I’m just trying to duplicate another pair, but for some reason, it just doesn’t work.

Ok. What firmware version are you working with?

VR(firmware Version):1008
VL(Verbose Firmware Version): Firmware version 1008.2[Factory] MAC only Jun 12 2017 13:15:27

Are you able to establish a socket to the ELIZA server on both modules?

No. Verizon provides private static IP address to us which means there is no Internet connection.

Try one of your working SIM cards in the module and see if the issue follows the SIM or not. If it follows the SIM, than it is time to talk to the provider.

I did a try. I swap my current working pair SIMs into those none-working ones and they are still working. Meanwhile, the none-working pair SIMs insert to the modules that originally contain working SIMs are still not working. It that means the problem is more provider side?

Yes that is exactly what that means. The issue is with the Provider and not the module.