Xbee Coordinator API using X-CTU Next Gen

I’m trying to update the firmware from Router AT to Coordinator API using X-CTU Next Gen.

The module programmation is OK but after applying the new configuration X-CTU needs to add again the module. Then I re-add the module but here is the problem (device not found). X-CTU does not recognize the module. I tried also to reset the module when the action is required.

However, if I use the old version X-CTU legacy, the module is recognized with the new firmware (Coordinator API). I think X-CTU legacy is not allowed on iOS and i usually work with a mac.

Thank you very much.

I have the exact same problem.

I work with Xbee Series 2 and whenever I load an API profile it stops seeing the module and if i try to add it again it says all the time Action Requested.

I work on an arduino wireless SD so every time it says reset I take it out and put it again, but nothing happens. I tried different versions of the firmware and also Router API, Coordinator API and nothing works.

I downloaded the Legacy XCTU and it can totally see the device and whenever I write an AT profile, the module works again even for the next gen XCTU.

Do you have any idea why this is happening?

I can do my work with Legacy but I would like to see the API frame builder in Next gen so much.

Anyways thank you

I could not find any solution to this problem but it works with Legacy…

In Arduino forum they told me to remove the ATMega chip but still not working. I also use a shield to connect my xBee. I execute an empty setup and loop functions instead of removíng the chip. You can try to do this maybe works with you. If you have other ideas…

Thank you very much

Have you tried to use the recovery function to perform the upgrade with and then discover the radio?

I tried the recovery but it doesn’t work. I mean when i first upgrade to API, then it doesn’t see it and it says action required, I go for the recovery mode choosing API but it says can’t find the bootloader.

Or do you mean something else?

What I am referring to is to use the XBee Recovery function located under the Tools menu in XCTU.

Hi mvut,
I also tried to use the XBee Recovery function in XCTU but the result is the same. I have the same problem.

Then what I would suggest is to use the Provide Feed back function and report what you are seeing to the developers.

hey do you have any news?

mine still not working