XBEE does not respond

I’ve started working on XBee 802.15.4 modules, but I’ve faced the following problems:

-When I tried to test the modules using loop back test, it was not working properly. For example, on terminal tap , when I wrote a letter, It showed a dot instead of displaying the same letter as an echo.

  • I noticed that one of the modules does not has a serial number that appears on modem configuration tab.

  • When I tried to connect the XBee Adapter with Vcc of 3.3V, it did not work,but It is working fine with Vdd of 5 V.

Could you help me to know what the problem is?

thank you

Han Ammar


Hello Han,

Did you configured the two modules properly? Remote XBee with loopback must have the DH and DL equals to the SH and SL of XBee on USB adapter.

  • I noticed that one of the modules does not has a serial number that appears on modem configuration tab.

You mean that XCTU didn’t show these parameters? That’s very strange, look for the serial number in the module’s back, normally it’s 0013A200-40xxxxxx.

Yes,I did
The problem of serial number has been solved. Actually, I changed the function set while I was trying to find a solution.

Now, the question is why dot appears on the screen?
why does it only work with 5 V? is soldering or WiFi affect ?

thank you

XBees are meant to be powered at 3,3 V, however, your adapter board migth have a regulator (is it a Digi XBIB? Check this link under “Support Documentation”), that’s why it migth need a higher voltage.

Dots in the terminal tab are usually non-printable characters (check with “Show Hex”) or an incorrect baudrate. Are you operating with AP=0 (transparent) or AP=1 (API frames)?

I’m operating it with AP=0.
I connected

  • remote Xbee with USB to serial cable and I used Hyper terminal.
  • other Xbee module to a laptop via USB port and I used X-CTU , it worked very well.

Then, I wrote a code for PIC18F4550 with remote Xbee to transmit a letter in order to display it on X-CTU terminal.
So,I connected RC6 of PIC to DIN of remote xbee and the other xbee connected with a laptop. It did not show anything. Is there any mistakes or settings need to be set?

#pragma config FOSC = HS
#pragma config PWRT = OFF
#pragma config BOR = OFF
#pragma config MCLRE = ON
#pragma config PBADEN = OFF
#pragma config ICPRT = OFF
#pragma config LVP = OFF
#pragma config WDT = OFF,DEBUG=OFF
//--------------- CONFIGRATION -----------//
#define D0 PORTDbits.RD0
#define Tx PORTCbits.RC6
void SerTx(unsigned char);
void main (void)
SPBRG=6;  // 4MHz crystal oscillator 

}//end main==================
void SerTx(unsigned char c)