Xbee usb connection

Hi there!

I have a problem with an XBee (former edition) module and the usb connection.

using X-CTU program and testing the following message returns:

Unable to communicate with modem

What shall i do??

“Unable to communicate with modem” is the same error one would get if no modem was connected to the serial port at all. Since you’re using a USB connection, have you installed the USB drivers?

The drivers can be found here:

If you have installed the USB drivers already, has this ever worked for you? Do you have the created USB “comm port” selected on the PC Settings tab in X-CTU rather than com 1 or something?

Please provide more detail on your setup, and whether or not this has ever worked for you.

By the way, I moved your thread as it was in the Terminal Server forum. I selected the 802.15.4 forum because it was closer to where the thread “should be” than the original forum it was found in, but if this is actually a “series 2” or ZNet 2.5 modem, please let me know so I can move it accordingly.

the drivers installed are those provided from the site you have mentioned above.

Is there something else i should do?